]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssl: Security fix CVE-2016-6302
authorArmin Kuster <akuster@mvista.com>
Sat, 24 Sep 2016 06:13:04 +0000 (23:13 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 27 Sep 2016 08:05:28 +0000 (09:05 +0100)
affects openssl < 1.0.1i

Signed-off-by: Armin Kuster <akuster@mvista.com>
meta/recipes-connectivity/openssl/openssl/CVE-2016-6302.patch [new file with mode: 0644]
meta/recipes-connectivity/openssl/openssl_1.0.2h.bb

diff --git a/meta/recipes-connectivity/openssl/openssl/CVE-2016-6302.patch b/meta/recipes-connectivity/openssl/openssl/CVE-2016-6302.patch
new file mode 100644 (file)
index 0000000..a72ee70
--- /dev/null
@@ -0,0 +1,53 @@
+From baaabfd8fdcec04a691695fad9a664bea43202b6 Mon Sep 17 00:00:00 2001
+From: "Dr. Stephen Henson" <steve@openssl.org>
+Date: Tue, 23 Aug 2016 18:14:54 +0100
+Subject: [PATCH] Sanity check ticket length.
+
+If a ticket callback changes the HMAC digest to SHA512 the existing
+sanity checks are not sufficient and an attacker could perform a DoS
+attack with a malformed ticket. Add additional checks based on
+HMAC size.
+
+Thanks to Shi Lei for reporting this bug.
+
+CVE-2016-6302
+
+Reviewed-by: Rich Salz <rsalz@openssl.org>
+
+Upstream-Status: Backport
+CVE: CVE-2016-6302
+Signed-off-by: Armin Kuster <akuster@mvista.com>
+
+---
+ ssl/t1_lib.c | 11 ++++++++---
+ 1 file changed, 8 insertions(+), 3 deletions(-)
+
+Index: openssl-1.0.2h/ssl/t1_lib.c
+===================================================================
+--- openssl-1.0.2h.orig/ssl/t1_lib.c
++++ openssl-1.0.2h/ssl/t1_lib.c
+@@ -3397,9 +3397,7 @@ static int tls_decrypt_ticket(SSL *s, co
+     HMAC_CTX hctx;
+     EVP_CIPHER_CTX ctx;
+     SSL_CTX *tctx = s->initial_ctx;
+-    /* Need at least keyname + iv + some encrypted data */
+-    if (eticklen < 48)
+-        return 2;
++
+     /* Initialize session ticket encryption and HMAC contexts */
+     HMAC_CTX_init(&hctx);
+     EVP_CIPHER_CTX_init(&ctx);
+@@ -3433,6 +3431,13 @@ static int tls_decrypt_ticket(SSL *s, co
+     if (mlen < 0) {
+         goto err;
+     }
++    /* Sanity check ticket length: must exceed keyname + IV + HMAC */
++    if (eticklen <= 16 + EVP_CIPHER_CTX_iv_length(&ctx) + mlen) {
++        HMAC_CTX_cleanup(&hctx);
++        EVP_CIPHER_CTX_cleanup(&ctx);
++        return 2;
++    }
++
+     eticklen -= mlen;
+     /* Check HMAC of encrypted ticket */
+     if (HMAC_Update(&hctx, etick, eticklen) <= 0
index 3d6474b1f75a7048f354cff042fe40324a659c55..8587f10a0788454b32e907f7dc65cd4391fab069 100644 (file)
@@ -45,6 +45,7 @@ SRC_URI += "file://find.pl;subdir=${BP}/util/ \
             file://CVE-2016-2181_p2.patch \
             file://CVE-2016-2181_p3.patch \
             file://CVE-2016-2182.patch \
+            file://CVE-2016-6302.patch \
            "
 SRC_URI[md5sum] = "9392e65072ce4b614c1392eefc1f23d0"
 SRC_URI[sha256sum] = "1d4007e53aad94a5b2002fe045ee7bb0b3d98f1a47f8b2bc851dcd1c74332919"