]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: install qmp module without hardcoding the python version in oeqa scripts
authorAlexander Kanavin <alex.kanavin@gmail.com>
Mon, 11 Oct 2021 09:40:35 +0000 (11:40 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 13 Oct 2021 08:41:39 +0000 (09:41 +0100)
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/lib/oeqa/utils/qemurunner.py
meta/recipes-devtools/qemu/qemu-system-native_6.1.0.bb

index d961a9a21836979ef4cc83d1841b2ca7badcb9b8..03971480825b3e9ec805980b6d77ee41f9e4b493 100644 (file)
@@ -183,7 +183,7 @@ class QemuRunner:
         # then add in the site-packages path components and add that
         # to the python sys.path so qmp.py can be found.
         python_path = os.path.dirname(os.path.dirname(self.logfile))
-        python_path += "/recipe-sysroot-native/usr/lib/python3.9/site-packages"
+        python_path += "/recipe-sysroot-native/usr/lib/qemu-python"
         sys.path.append(python_path)
         importlib.invalidate_caches()
         try:
index b47ffd5262764dc4312bff82f5c8840e5e23e4d2..b544ab4e817cb8e118eedd75d2156cb6eac22697 100644 (file)
@@ -28,5 +28,5 @@ do_install:append() {
     rm -rf ${D}${includedir}/qemu-plugin.h
 
     # Install qmp.py to be used with testimage
-    install -D ${S}/python/qemu/qmp/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/qmp.py
+    install -D ${S}/python/qemu/qmp/__init__.py ${D}${libdir}/qemu-python/qmp.py
 }