]> code.ossystems Code Review - openembedded-core.git/commitdiff
documentation/poky-ref-manual: expand discussion of PR and INC_PR
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Thu, 23 Dec 2010 13:44:05 +0000 (13:44 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 20 Jan 2011 21:37:00 +0000 (21:37 +0000)
Expands a little on PR and INC_PR.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
documentation/poky-ref-manual/extendpoky.xml
documentation/poky-ref-manual/ref-variables.xml

index 92f51a56f947149edf56f801b6910c4c14bdd086..4fd818e8b11718fe344e1897dbac20113d73e8bf 100644 (file)
@@ -685,15 +685,20 @@ BBFILE_PRIORITY_emenlow = "6"
                 This means that for new recipes you must be sure to add the PR variable and set its initial value
                 equal to "r0".  
                 Failing to define PR makes it easy to miss when you bump a package.
-                Note that you can only use integer values for the PR variable.
+                Note that you can only use integer values following the "r" in the PR variable.
             </para>
             <para>
-                You can also use the <glossterm><link linkend='var-INC_PR'>INC_PR</link></glossterm> variable
-                to keep up with package revisioning.
-            </para>
+                If you are sharing a common .inc file with multiple recipes, you can also use the 
+                <glossterm><link linkend='var-INC_PR'>INC_PR</link></glossterm> variable to ensure that 
+                the recipes sharing the .inc file are rebuilt when the .inc file itself is changed. The
+                .inc file must set INC_PR (initially to "r0"), and all recipes referring to it should set PR to 
+                "$(INC_PR).0" initially, incrementing the last number when the recipe is changed. If the
+                .inc file is changed then its INC_PR should be incremented.
+            </literallayout>
             <para> 
-                When upgrading the version of a package the (<glossterm><link 
-                linkend='var-PV'>PV</link></glossterm>) and PR variables should be reset to "r0".
+                When upgrading the version of a package, assuming the <glossterm><link 
+                linkend='var-PV'>PV</link></glossterm> changes, the PR variable should be reset to "r0"
+                (or "$(INC_PR).0" if you are using INC_PR).
             </para>
             <para>
                 Usually, version increases occur only to packages.
index 98a501f3994850511956a7fe187676496c5d514e..da57e2c3846f68bf90a3da728f65b8ac1656d6a0 100644 (file)
@@ -609,7 +609,7 @@ recipes-graphics/xorg-font/fiont-alias_1.0.2.bb:PR - "$(INC_PR).0"
 
         <glossentry id='var-PR'><glossterm>PR</glossterm>
             <glossdef>
-                <para>Revision of package.
+                <para>Revision of package. The default value is "r0".
                     </para>
             </glossdef>
         </glossentry>
@@ -617,7 +617,11 @@ recipes-graphics/xorg-font/fiont-alias_1.0.2.bb:PR - "$(INC_PR).0"
         <glossentry id='var-PV'><glossterm>PV</glossterm>
             <glossdef>
                 <para>Version of package.
-                    The default value is "1.0"</para>
+                    This is normally extracted from the recipe name, e.g. if the recipe is named 
+                    "expat_2.0.1.bb" then PV will be "2.0.1". PV is generally not overridden within 
+                    a recipe unless it is building an unstable version from a source code repository 
+                    (git, svn, etc.).
+                 </para>
             </glossdef>
         </glossentry>