]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel-devsrc: fix 5.14+ objtool compilation
authorBruce Ashfield <bruce.ashfield@gmail.com>
Tue, 17 Aug 2021 15:27:32 +0000 (11:27 -0400)
committerAnuj Mittal <anuj.mittal@intel.com>
Wed, 25 Aug 2021 02:44:50 +0000 (10:44 +0800)
In v5.14+, x86 requires not just elfutils, but the elf headers
on the target to build objtool (required for 'scripts parepare'),
so we tweak our RDEPENDS to ensure that the right headers are
on the target.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 03ccc234386f753e1b0129ec557e67bcd04cc69e)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-kernel/linux/kernel-devsrc.bb

index 4897084aab35f85bd8fa189b3a780f806b953348..a5eba7c03a816761c5a26bb606544e23f08de678 100644 (file)
@@ -320,7 +320,7 @@ RDEPENDS_${PN} = "bc python3 flex bison ${TCLIBC}-utils"
 # 4.15+ needs these next two RDEPENDS
 RDEPENDS_${PN} += "openssl-dev util-linux"
 # and x86 needs a bit more for 4.15+
-RDEPENDS_${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils', '', d)}"
+RDEPENDS_${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-dev', '', d)}"
 # 5.8+ needs gcc-plugins libmpc-dev
 RDEPENDS_${PN} += "gcc-plugins libmpc-dev"
 # 5.13+ needs awk for arm64