]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxp: fix cast error
authorSaul Wold <sgw@linux.intel.com>
Thu, 5 Jan 2012 00:46:27 +0000 (16:46 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 5 Jan 2012 11:14:51 +0000 (11:14 +0000)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/xorg-lib/libxp/fix-cast-error.patch [new file with mode: 0644]
meta/recipes-graphics/xorg-lib/libxp_1.0.1.bb

diff --git a/meta/recipes-graphics/xorg-lib/libxp/fix-cast-error.patch b/meta/recipes-graphics/xorg-lib/libxp/fix-cast-error.patch
new file mode 100644 (file)
index 0000000..fea18cf
--- /dev/null
@@ -0,0 +1,42 @@
+This patch fixes these new errors:
+
+| XpNotifyPdm.c:234:10: error: cast from pointer to integer of different size [-Werror=pointer-to-int-cast]
+| XpNotifyPdm.c:271:10: error: cast from pointer to integer of different size [-Werror=pointer-to-int-cast]
+| XpNotifyPdm.c:286:10: error: cast from pointer to integer of different size [-Werror=pointer-to-int-cast]
+
+
+Upstream-Status: Pending
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: libXp-1.0.1/src/XpNotifyPdm.c
+===================================================================
+--- libXp-1.0.1.orig/src/XpNotifyPdm.c
++++ libXp-1.0.1/src/XpNotifyPdm.c
+@@ -231,7 +231,7 @@ XpGetPdmStartParams (
+       /*
+        * Error - cannot determine or establish a selection_display.
+        */
+-      return( (Status) NULL );
++      return( (Status) 0 );
+     }
+     /*
+@@ -268,7 +268,7 @@ XpGetPdmStartParams (
+           XCloseDisplay( *selection_display );
+           *selection_display = (Display *) NULL;
+       }
+-      return( (Status) NULL );
++      return( (Status) 0 );
+     }
+     status = XmbTextListToTextProperty( *selection_display, list, 6,
+@@ -283,7 +283,7 @@ XpGetPdmStartParams (
+           XCloseDisplay( *selection_display );
+           *selection_display = (Display *) NULL;
+       }
+-      return( (Status) NULL );
++      return( (Status) 0 );
+     }
+     *type              = text_prop.encoding;
index a19f561fa73994347efae470a02a3778cb813249..349dad1c44e57dd3824cb172b5f285d5407c4f0a 100644 (file)
@@ -10,12 +10,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=9504a1264f5ddd4949254a57c0f8d6bb \
                     file://src/XpPage.c;beginline=2;endline=35;md5=2b7d3d2ba5505b19271cf31b6918997e"
 
 DEPENDS += "libxext libxau printproto"
-PR = "r0"
+PR = "r1"
 PE = "1"
 
 XORG_PN = "libXp"
 
 CFLAGS_append += " -I ${S}/include/X11/XprintUtil -I ${S}/include/X11/extensions"
 
+SRC_URI += "file://fix-cast-error.patch"
+
 SRC_URI[md5sum] = "7ae1d63748e79086bd51a633da1ff1a9"
 SRC_URI[sha256sum] = "71d1f260005616d646b8c8788365f2b7d93911dac57bb53b65753d9f9e6443d2"