]> code.ossystems Code Review - openembedded-core.git/commitdiff
gawk: fix libexec of the old 3.1.5 version
authorChen Qi <Qi.Chen@windriver.com>
Fri, 6 Jun 2014 02:28:19 +0000 (10:28 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 10 Jun 2014 16:14:36 +0000 (17:14 +0100)
${libexec} doesn't necessarily equals to ${libdir}/${BPN}. So fix
this problem by using ${libdir}/${BPN} in FILES variable.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/gawk/gawk_3.1.5.bb

index 48e8939a895086f9b558ffaa574f2a40606b0d71..c7af4a9b72c6e0b868e72b2f080a4d31fa2bb964 100644 (file)
@@ -26,9 +26,9 @@ inherit autotools gettext texinfo update-alternatives
 PACKAGES += "gawk-common pgawk"
 
 FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk"
-FILES_gawk-common += "${datadir}/awk/* ${libexecdir}/awk/*"
+FILES_gawk-common += "${datadir}/awk/* ${libdir}/gawk/awk/*"
 FILES_pgawk = "${bindir}/pgawk*"
-FILES_${PN}-dbg += "${libexecdir}/awk/.debug"
+FILES_${PN}-dbg += "${libdir}/gawk/awk/.debug"
 
 ALTERNATIVE_${PN} = "awk"
 ALTERNATIVE_TARGET[awk] = "${bindir}/gawk"