]> code.ossystems Code Review - openembedded-core.git/commitdiff
autotools.bbclass: force copy Makefile.in.in to ${S}/po/
authorRoy.Li <rongqing.li@windriver.com>
Wed, 26 Jun 2013 01:58:35 +0000 (09:58 +0800)
committerSaul Wold <sgw@linux.intel.com>
Thu, 27 Jun 2013 16:55:58 +0000 (09:55 -0700)
If a Makefile.in.in has existed under ${S}/po/ and is read-only, cp will fail.

Signed-off-by: Roy.Li <rongqing.li@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/classes/autotools.bbclass

index 66c0f5d10a21e27c55455ce803266424c01015b6..4e4ef986bf70568da0c6488c424430bb5e0a2acb 100644 (file)
@@ -201,7 +201,7 @@ autotools_do_configure() {
                        # We'd call gettextize here if it wasn't so broken...
                                cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
                                if [ -d ${S}/po/ ]; then
-                                       cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po/
+                                       cp -f ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po/
                                        if [ ! -e ${S}/po/remove-potcdate.sin ]; then
                                                cp ${STAGING_DATADIR_NATIVE}/gettext/po/remove-potcdate.sin ${S}/po/
                                        fi