]> code.ossystems Code Review - openembedded-core.git/commitdiff
avahi-ui: support usrmerge
authorChangqing Li <changqing.li@windriver.com>
Fri, 30 Aug 2019 07:37:46 +0000 (15:37 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 30 Aug 2019 21:30:23 +0000 (22:30 +0100)
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/avahi/avahi-ui_0.7.bb

index a77653bf55d76173325440f078806e2060ff25c5..1c6e46aabab468e78bf947c2b57587a25f361abe 100644 (file)
@@ -20,7 +20,13 @@ FILES_avahi-discover = "${datadir}/applications/avahi-discover.desktop \
 
 do_install_append () {
        rm ${D}${sysconfdir} -rf
-       rm ${D}${base_libdir} -rf
+       if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
+               if [ "${nonarch_base_libdir}" != "${base_libdir}" ];then
+                   rm ${D}${nonarch_base_libdir} -rf
+               fi
+        else
+               rm ${D}${base_libdir} -rf
+        fi
        rm ${D}${systemd_unitdir} -rf
        # The ${systemd_unitdir} is /lib/systemd, so we need rmdir /lib,
        # but not ${base_libdir} here. And the /lib may not exist