]> code.ossystems Code Review - openembedded-core.git/commitdiff
apr: Fix multilib header conflict - apr.h
authorMark Hatle <mark.hatle@windriver.com>
Tue, 26 Jul 2011 17:58:58 +0000 (12:58 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Jul 2011 14:39:17 +0000 (15:39 +0100)
apr.h conflicts between 32-bit and 64-bit versions

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-support/apr/apr_1.4.2.bb

index 89bdadf9551cf5675215816505aeb6a53e13938c..b37001d4cacff48a46952ec0f9c5f0287c77b08f 100644 (file)
@@ -6,7 +6,7 @@ LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=0c35ff3c4c83b89d2f076e315caac28b \
                     file://include/apr_lib.h;endline=17;md5=ee42fa7575dc40580a9e01c1b75fae96"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
            file://configure_fixes.patch;patch=1 \
@@ -17,7 +17,7 @@ SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
 SRC_URI[md5sum] = "4b00e8f70c067893d075577962656b35"
 SRC_URI[sha256sum] = "2017ca700694d09d2b0b21dd7c4d195e43a48735aac88526160c6195ee8f5391"
 
-inherit autotools lib_package binconfig
+inherit autotools lib_package binconfig multilib_header
 
 OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
 
@@ -34,6 +34,10 @@ do_configure_append() {
        sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' build/apr_rules.mk
 }
 
+do_install_append() {
+       oe_multilib_header apr.h
+}
+
 SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
 
 apr_sysroot_preprocess () {