]> code.ossystems Code Review - openembedded-core.git/commitdiff
tiff: Secruity fix CVE-2016-10093
authorRajkumar Veer <rveer@mvista.com>
Sat, 4 Nov 2017 04:39:26 +0000 (21:39 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 21 Nov 2017 14:42:53 +0000 (14:42 +0000)
Signed-off-by: Rajkumar Veer <rveer@mvista.com>
Signed-off-by: Armin Kuster <akuster@mvista.com>
meta/recipes-multimedia/libtiff/files/CVE-2016-10093.patch [new file with mode: 0644]
meta/recipes-multimedia/libtiff/tiff_4.0.7.bb

diff --git a/meta/recipes-multimedia/libtiff/files/CVE-2016-10093.patch b/meta/recipes-multimedia/libtiff/files/CVE-2016-10093.patch
new file mode 100644 (file)
index 0000000..e09bb7f
--- /dev/null
@@ -0,0 +1,47 @@
+From 787c0ee906430b772f33ca50b97b8b5ca070faec Mon Sep 17 00:00:00 2001
+From: erouault <erouault>
+Date: Sat, 3 Dec 2016 16:40:01 +0000
+Subject: [PATCH] * tools/tiffcp.c: fix uint32 underflow/overflow that can
+ cause heap-based buffer overflow. Reported by Agostino Sarubbo. Fixes
+ http://bugzilla.maptools.org/show_bug.cgi?id=2610
+
+Upstream-Status: Backport
+CVE: CVE-2016-10093
+Signed-off-by: Rajkumar Veer <rveer@mvista.com>
+
+---
+ ChangeLog      | 7 +++++++
+ tools/tiffcp.c | 6 +++---
+ 2 files changed, 10 insertions(+), 3 deletions(-)
+
+Index: tiff-4.0.7/tools/tiffcp.c
+===================================================================
+--- tiff-4.0.7.orig/tools/tiffcp.c
++++ tiff-4.0.7/tools/tiffcp.c
+@@ -1163,7 +1163,7 @@ bad:
+ static void
+ cpStripToTile(uint8* out, uint8* in,
+-    uint32 rows, uint32 cols, int outskew, int inskew)
++    uint32 rows, uint32 cols, int outskew, int64 inskew)
+ {
+       while (rows-- > 0) {
+               uint32 j = cols;
+@@ -1320,7 +1320,7 @@ DECLAREreadFunc(readContigTilesIntoBuffe
+       tdata_t tilebuf;
+       uint32 imagew = TIFFScanlineSize(in);
+       uint32 tilew  = TIFFTileRowSize(in);
+-      int iskew = imagew - tilew;
++      int64 iskew = (int64)imagew - (int64)tilew;
+       uint8* bufp = (uint8*) buf;
+       uint32 tw, tl;
+       uint32 row;
+@@ -1348,7 +1348,7 @@ DECLAREreadFunc(readContigTilesIntoBuffe
+                               status = 0;
+                               goto done;
+                       }
+-                      if (colb + tilew > imagew) {
++                      if (colb > iskew) {
+                               uint32 width = imagew - colb;
+                               uint32 oskew = tilew - width;
+                               cpStripToTile(bufp + colb,
index 48f7986698029ef3c593f2f6a44da142c5bcf91e..5d816fc7ae6409464b270fc0f00abf62e407fa99 100644 (file)
@@ -12,6 +12,7 @@ SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
            file://CVE-2017-10688.patch \
            file://CVE-2017-11335.patch \
            file://CVE-2016-10271.patch \
+           file://CVE-2016-10093.patch \
           "
 
 SRC_URI[md5sum] = "77ae928d2c6b7fb46a21c3a29325157b"