]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: Fix adding GDBM_File module for LSB test.
authorJingdong Lu <jingdong.lu@windriver.com>
Mon, 1 Nov 2010 09:58:09 +0000 (17:58 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 10 Dec 2010 23:13:00 +0000 (23:13 +0000)
No GDBM_File module will cause 2 perl test cases of LSB failed.

Signed-off-by: Jingdong Lu <jingdong.lu@windriver.com>
meta/recipes-devtools/perl/perl-5.8.8/config.sh
meta/recipes-devtools/perl/perl-5.8.8/perl-enable-gdbm.patch [new file with mode: 0644]
meta/recipes-devtools/perl/perl_5.8.8.bb

index 8d1f904f2010bcb84a07f1ba8a2000ea9f9163c7..3d4c193a3d9e1c8467d83ec28ce35d4cef77a6a2 100644 (file)
@@ -507,7 +507,7 @@ dlsrc='dl_dlopen.xs'
 doublesize='8'
 drand01='drand48()'
 drand48_r_proto='REENTRANT_PROTO_I_ST'
-dynamic_ext='attrs B ByteLoader Cwd Data/Dumper Devel/DProf Devel/Peek Devel/PPPort Digest/MD5 Encode Fcntl File/Glob Filter/Util/Call I18N/Langinfo IO IPC/SysV List/Util MIME/Base64 Opcode PerlIO/encoding PerlIO/scalar PerlIO/via POSIX re SDBM_File Socket Storable Sys/Hostname Sys/Syslog threads Time/HiRes Unicode/Normalize XS/APItest XS/Typemap threads/shared'
+dynamic_ext='attrs B ByteLoader Cwd Data/Dumper Devel/DProf Devel/Peek Devel/PPPort Digest/MD5 Encode Fcntl File/Glob Filter/Util/Call I18N/Langinfo IO IPC/SysV List/Util MIME/Base64 Opcode PerlIO/encoding PerlIO/scalar PerlIO/via POSIX re GDBM_File SDBM_File Socket Storable Sys/Hostname Sys/Syslog threads Time/HiRes Unicode/Normalize XS/APItest XS/Typemap threads/shared'
 eagain='EAGAIN'
 ebcdic='undef'
 echo='echo'
@@ -593,7 +593,7 @@ i_fcntl='undef'
 i_float='define'
 i_fp='undef'
 i_fp_class='undef'
-i_gdbm='undef'
+i_gdbm='define'
 i_grp='define'
 i_ieeefp='undef'
 i_inttypes='define'
@@ -981,7 +981,7 @@ zcat=''
 zip='zip'
 # Configure command line arguments.
 config_arg0='Configure'
-config_args='-des -Doptimize=-O2 -Dmyhostname=localhost -Dperladmin=root@localhost -Dcc=gcc -Dcf_by=Open Embedded -Dprefix=/usr -Dvendorprefix=/usr -Dsiteprefix=/usr -Dotherlibdirs=/usr/lib/perl5/5.8.8 -Duseshrplib -Dusethreads -Duseithreads -Duselargefiles -Ud_dosuid -Dd_semctl_semun -Ui_db -Ui_ndbm -Ui_gdbm -Di_shadow -Di_syslog -Dman3ext=3pm -Duseperlio -Dinstallusrbinperl -Ubincompat5005 -Uversiononly -Dpager=/usr/bin/less -isr'
+config_args='-des -Doptimize=-O2 -Dmyhostname=localhost -Dperladmin=root@localhost -Dcc=gcc -Dcf_by=Open Embedded -Dprefix=/usr -Dvendorprefix=/usr -Dsiteprefix=/usr -Dotherlibdirs=/usr/lib/perl5/5.8.8 -Duseshrplib -Dusethreads -Duseithreads -Duselargefiles -Ud_dosuid -Dd_semctl_semun -Ui_db -Ui_ndbm -Di_gdbm -Di_shadow -Di_syslog -Dman3ext=3pm -Duseperlio -Dinstallusrbinperl -Ubincompat5005 -Uversiononly -Dpager=/usr/bin/less -isr'
 config_argc=27
 config_arg1='-des'
 config_arg2='-Doptimize=-O2'
@@ -1001,7 +1001,7 @@ config_arg15='-Ud_dosuid'
 config_arg16='-Dd_semctl_semun'
 config_arg17='-Ui_db'
 config_arg18='-Ui_ndbm'
-config_arg19='-Ui_gdbm'
+config_arg19='-Di_gdbm'
 config_arg20='-Di_shadow'
 config_arg21='-Di_syslog'
 config_arg22='-Dman3ext=3pm'
diff --git a/meta/recipes-devtools/perl/perl-5.8.8/perl-enable-gdbm.patch b/meta/recipes-devtools/perl/perl-5.8.8/perl-enable-gdbm.patch
new file mode 100644 (file)
index 0000000..c0874c3
--- /dev/null
@@ -0,0 +1,17 @@
+Index: perl-5.8.8/config_h.SH
+===================================================================
+--- perl-5.8.8.orig/config_h.SH        2005-11-01 02:13:05.000000000 +0800
++++ perl-5.8.8/config_h.SH     2010-11-01 17:06:07.215219738 +0800
+@@ -709,6 +709,12 @@
+  */
+ #$i_float I_FLOAT             /**/
++/* I_GDBM:
++ *      This symbol, if defined, indicates that <gdbm.h> exists and should
++ *      be included.
++ */
++#$i_gdbm I_GDBM /**/
++
+ /* I_LIMITS:
+  *    This symbol, if defined, indicates to the C program that it should
+  *    include <limits.h> to get definition of symbols like WORD_BIT or
index 2774942ba219d1bad86f4eaf626551ee7c109474..2515b6e0b9e14f5dea98e96f1b93abff8220145a 100644 (file)
@@ -7,7 +7,8 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
 PRIORITY = "optional"
 # We need gnugrep (for -I)
 DEPENDS = "virtual/db perl-native grep-native"
-PR = "r20"
+DEPENDS += "gdbm"
+PR = "r21"
 
 # Major part of version
 PVM = "5.8"
@@ -32,6 +33,7 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
         file://64_debian_enc2xs_inc.patch;patch=1 \
         file://asm-pageh-fix.patch;patch=1 \
         file://native-perlinc.patch;patch=1 \
+       file://perl-enable-gdbm.patch;patch=1 \
         file://config.sh \
         file://config.sh-32 \
         file://config.sh-32-le \