]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxsettings-client: fix COPYING file
authorRobert Yang <liezhi.yang@windriver.com>
Wed, 27 Apr 2016 02:20:30 +0000 (19:20 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 Jun 2016 18:33:25 +0000 (19:33 +0100)
Fixed:
* Move the code of copy COPYING file from do_configure_append() to
  do_patch[postfuncs] since we had moved license-checksum from
  do_package_qa to do_populate_lic.
* Add xsettings-client.c and xsettings-common.c to LIC_FILES_CHKSUM.
* Update comments.

(From OE-Core rev: 89332686ac6c756672cbf67c2df70c5150efa998)

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster@mvista.com>
meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb

index 67c5e2777637f1f8b452e60e78b7ff25cd82733f..9e9336e5db023141221c5ba0a884d471705c0797 100644 (file)
@@ -9,7 +9,9 @@ SECTION = "x/libs"
 LICENSE = "MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
                     file://xsettings-client.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
-                    file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
+                    file://xsettings-client.c;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
+                    file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
+                    file://xsettings-common.c;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
 DEPENDS = "virtual/libx11"
 
 PR = "r5"
@@ -31,10 +33,11 @@ inherit autotools gettext distro_features_check
 # depends on virtual/libx11
 REQUIRED_DISTRO_FEATURES = "x11"
 
-do_configure_prepend() {
-    # This package doesn't ship with its own COPYING file and
-    # autotools will install a GPLv2 one instead of the actual MIT-style license here.
-    # Add the correct license here to avoid confusion.
+do_patch[postfuncs] += "update_copying_file"
+update_copying_file() {
+    # This package ships with a GPLv2 COPYING file, but the author says
+    # it is actual MIT-style license, add the correct license here to
+    # avoid confusion.
     cp -f ${WORKDIR}/MIT-style-license ${S}/COPYING
 }