]> code.ossystems Code Review - openembedded-core.git/commitdiff
web-webkit: link with g++
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 31 Jan 2008 17:49:33 +0000 (17:49 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 31 Jan 2008 17:49:33 +0000 (17:49 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3650 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/web/web-webkit/link-with-g++.patch [new file with mode: 0644]
meta/packages/web/web-webkit_svn.bb

diff --git a/meta/packages/web/web-webkit/link-with-g++.patch b/meta/packages/web/web-webkit/link-with-g++.patch
new file mode 100644 (file)
index 0000000..946d950
--- /dev/null
@@ -0,0 +1,19 @@
+---
+ src/Makefile.am |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- webkit.orig/src/Makefile.am
++++ webkit/src/Makefile.am
+@@ -1,11 +1,11 @@
+ AM_CPPFLAGS=-DPKGDATADIR=\"$(pkgdatadir)\"
+ AM_CFLAGS = -Wall -export-dynamic $(WEB_CFLAGS)
+ bin_PROGRAMS = web2
+-web2_SOURCES = web2.h web2-main.c web2-utils.c web2-utils.h
++web2_SOURCES = web2.h web2-main.c web2-utils.c web2-utils.h dummy.cpp
+ web2_LDADD   = $(WEB_LIBS)
+ MAINTAINERCLEANFILES = config.h.in Makefile.in
+ uidir = $(pkgdatadir)
index 0ffca7483f7a4d58ec31a26a7606b2edb53fe28d..227c86de44a78590d43c6ca87599c235f260864e 100644 (file)
@@ -4,11 +4,17 @@ SECTION = "x11"
 DEPENDS = "libxml2 glib-2.0 gtk+ libglade webkit-gtk curl gconf js libowl"
 
 PV = "0.0+svnr${SRCREV}"
+PR = "r1"
 
-SRC_URI = "svn://svn.o-hand.com/repos/web/branches;module=webkit;proto=http"
+SRC_URI = "svn://svn.o-hand.com/repos/web/branches;module=webkit;proto=http \
+           file://link-with-g++.patch;patch=1"
 
 S = "${WORKDIR}/webkit"
 
 inherit autotools pkgconfig gconf
 
+do_configure_prepend() {
+    touch ${S}/src/dummy.cpp
+}
+
 FILES_${PN} += "${datadir}/web2"