]> code.ossystems Code Review - openembedded-core.git/commitdiff
useradd-example: add example for setting clear text password
authorChen Qi <Qi.Chen@windriver.com>
Tue, 10 Dec 2013 09:40:37 +0000 (17:40 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 14 Dec 2013 09:16:32 +0000 (09:16 +0000)
Use '-P' option for user3 to set a clear text password. This is supposed
to serve as an example of how to set clear text password in recipes.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta-skeleton/recipes-skeleton/useradd/useradd-example.bb

index 53d2340af50658cc4b3375d42d7b253d009b12ff..2f8d9b072f1d814c251f8c7081a95784a667f612 100644 (file)
@@ -32,7 +32,8 @@ USERADD_PACKAGES = "${PN} ${PN}-user3"
 USERADD_PARAM_${PN} = "-u 1200 -d /home/user1 -r -s /bin/bash user1; -u 1201 -d /home/user2 -r -s /bin/bash user2"
 
 # user3 will be managed in the useradd-example-user3 pacakge:
-USERADD_PARAM_${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash user3"
+# As an example, we use the -P option to set clear text password for user3
+USERADD_PARAM_${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash -P 'user3' user3"
 
 # GROUPADD_PARAM works the same way, which you set to the options
 # you'd normally pass to the groupadd command. This will create