]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa-7.11: move shared DEPENDS, SRC_URI, checksums and do_configure_prepend to shared...
authorMartin Jansa <Martin.Jansa@gmail.com>
Thu, 13 Oct 2011 07:57:28 +0000 (09:57 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 14 Oct 2011 11:18:21 +0000 (12:18 +0100)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
meta/recipes-graphics/mesa/mesa-7.11.inc [new file with mode: 0644]
meta/recipes-graphics/mesa/mesa-dri_7.11.bb
meta/recipes-graphics/mesa/mesa-xlib_7.11.bb

diff --git a/meta/recipes-graphics/mesa/mesa-7.11.inc b/meta/recipes-graphics/mesa/mesa-7.11.inc
new file mode 100644 (file)
index 0000000..746b764
--- /dev/null
@@ -0,0 +1,14 @@
+DEPENDS += "mesa-dri-glsl-native"
+
+SRC_URI += "file://uclibc.patch \
+            file://crossfix.patch \
+           "
+SRC_URI[md5sum] = "ff03aca82d0560009a076a87c888cf13"
+SRC_URI[sha256sum] = "f8bf37a00882840a3e3d327576bc26a79ae7f4e18fe1f7d5f17a5b1c80dd7acf"
+
+do_configure_prepend() {
+  #check for python not python2, because python-native does not stage python2 binary/link
+  sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
+  # We need builtin_compiler built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
+  sed -i "s#\./builtin_compiler#${STAGING_BINDIR_NATIVE}/glsl/builtin_compiler#g" ${S}/src/glsl/Makefile
+}
index 5f14346ee141bed2b20731be3dddbf0756bdedc3..90873aab481e50d6de5b0f28c27a09e0a1a54864 100644 (file)
@@ -1,22 +1,14 @@
 include mesa-common.inc
+include mesa-${PV}.inc
 
 PROTO_DEPS = "xf86driproto glproto dri2proto"
 LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat \
             libxml2-native"
 
 DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS} makedepend-native python-native"
-DEPENDS += "mesa-dri-glsl-native"
 
 PR = "${INC_PR}.0"
 
-SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
-           file://crossfix.patch \
-           file://uclibc.patch \
-          "
-
-SRC_URI[md5sum] = "ff03aca82d0560009a076a87c888cf13"
-SRC_URI[sha256sum] = "f8bf37a00882840a3e3d327576bc26a79ae7f4e18fe1f7d5f17a5b1c80dd7acf"
-
 # most of our targets do not have DRI so will use mesa-xlib
 DEFAULT_PREFERENCE = "-1"
 
@@ -37,10 +29,3 @@ COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)'
 PACKAGES_DYNAMIC = "mesa-dri-driver-*"
 
 FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
-
-do_configure_prepend() {
-       #check for python not python2, because python-native does not stage python2 binary/link
-       sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
-       # We need builtin_compiler built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
-       sed -i "s#\./builtin_compiler#${STAGING_BINDIR_NATIVE}/glsl/builtin_compiler#g" ${S}/src/glsl/Makefile
-}
index 1e0d8211a418f68a97d47cd9f21671c3fe2d0d46..44719a081e09b5cc174abb271c2a231e4a78fa35 100644 (file)
@@ -1,11 +1,5 @@
 include mesa-common.inc
-
-SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
-           file://uclibc.patch \
-           "
-
-SRC_URI[md5sum] = "ff03aca82d0560009a076a87c888cf13"
-SRC_URI[sha256sum] = "f8bf37a00882840a3e3d327576bc26a79ae7f4e18fe1f7d5f17a5b1c80dd7acf"
+include mesa-${PV}.inc
 
 PROTO_DEPS = "xf86driproto glproto"
 LIB_DEPS = "virtual/libx11 libxext libxxf86vm libxdamage libxfixes libxml2-native"
@@ -15,11 +9,3 @@ DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS} makedepend-native"
 PR = "${INC_PR}.0"
 
 EXTRA_OECONF += "--with-driver=xlib --without-gallium-drivers"
-
-do_configure_prepend() {
-       #check for python not python2, because python-native does not stage python2 binary/link
-       sed -i 's/AC_CHECK_PROGS(\[PYTHON2\], \[python2 python\])/AC_CHECK_PROGS(\[PYTHON2\], \[python python\])/g' ${S}/configure.ac
-       # We need builtin_compiler built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
-       sed -i "s#\./builtin_compiler#${STAGING_BINDIR_NATIVE}/glsl/builtin_compiler#g" ${S}/src/glsl/Makefile
-}
-