]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml2: move xmlcatalog and xmllint back into libxml2-utils
authorAndre McCurdy <armccurdy@gmail.com>
Wed, 10 Oct 2018 01:04:18 +0000 (18:04 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Oct 2018 11:42:40 +0000 (12:42 +0100)
Packaging of libxml2-utils has been broken since 2011:

  http://git.openembedded.org/openembedded-core/commit/?id=76052861cc95fd4ad4c4b9eb6ce4cd1065ad4dc9

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/libxml/libxml2_2.9.8.bb

index f01cb2cd348c8a6c07699f8096a3eb83899447e0..d35f60832af8bd2949fc8dbd5164b2d0f56feeed 100644 (file)
@@ -67,12 +67,13 @@ python populate_packages_prepend () {
         d.setVar('PKG_libxml2', '${MLPREFIX}libxml2')
 }
 
-PACKAGES += "${PN}-utils ${PN}-python"
+PACKAGE_BEFORE_PN += "${PN}-utils"
+PACKAGES += "${PN}-python"
 
 FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
 FILES_${PN}-dev += "${libdir}/xml2Conf.sh ${libdir}/cmake/*"
-FILES_${PN}-utils += "${bindir}/*"
-FILES_${PN}-python += "${PYTHON_SITEPACKAGES_DIR}"
+FILES_${PN}-utils = "${bindir}/*"
+FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
 
 do_configure_prepend () {
        # executables take longer to package: these should not be executable