]> code.ossystems Code Review - openembedded-core.git/commitdiff
harfbuzz: add recipe, version 0.9.10
authorMarko Lindqvist <cazfi74@gmail.com>
Wed, 9 Jan 2013 12:13:53 +0000 (14:13 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 10 Jan 2013 23:42:36 +0000 (23:42 +0000)
OpenType text shaping engine HarfBuzz is dependency of pango >= 1.32
This depends on all of glib-2.0, cairo, and freetype to consistently
provide all backends. Otherwise it would, in typical case, depend
on build order of these packages. HarfBuzz configure would pick those
backends for which dependencies happen to be built before it.
Similarly graphite is consistenly disabled if there ever happens
to be recipe for it.

Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-graphics/harfbuzz/harfbuzz-0.9.10/disable_graphite.patch [new file with mode: 0644]
meta/recipes-graphics/harfbuzz/harfbuzz_0.9.10.bb [new file with mode: 0644]

diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz-0.9.10/disable_graphite.patch b/meta/recipes-graphics/harfbuzz/harfbuzz-0.9.10/disable_graphite.patch
new file mode 100644 (file)
index 0000000..49938ba
--- /dev/null
@@ -0,0 +1,15 @@
+Upstream-Status: Inappropriate [disable feature]
+
+Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
+diff -Nurd harfbuzz-0.9.10/configure.ac harfbuzz-0.9.10/configure.ac
+--- harfbuzz-0.9.10/configure.ac       2013-01-03 08:08:51.000000000 +0200
++++ harfbuzz-0.9.10/configure.ac       2013-01-09 08:18:04.812529418 +0200
+@@ -185,7 +185,7 @@
+
+ dnl ==========================================================================
+
+-PKG_CHECK_MODULES(GRAPHITE2, graphite2, have_graphite=true, have_graphite=false)
++have_graphite=false
+ if $have_graphite; then
+     AC_DEFINE(HAVE_GRAPHITE2, 1, [Have Graphite library])
+ fi
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_0.9.10.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_0.9.10.bb
new file mode 100644 (file)
index 0000000..0dd6301
--- /dev/null
@@ -0,0 +1,29 @@
+SUMMARY = "Text shaping library"
+DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
+HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
+BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
+
+LICENSE = "Old-MIT | UCDN | ICU | HarfBuzz-old"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e021dd6dda6ff1e6b1044002fc662b9b \
+                    file://src/hb-ucdn/COPYING;md5=994ba0f1295f15b4bda4999a5bbeddef \
+                    file://src/hb-icu-le/COPYING;md5=0ac60acf068e2cc9facdf86169a9c13e \
+                    file://src/hb-icu-le/license.html;md5=9136737088bbfbbf86d9a714da49fb89 \
+                    file://src/hb-old/COPYING;md5=6e8442c12d498ce55cfe39fc60f97981 \
+"
+
+SECTION = "libs"
+
+PR = "r0"
+
+SRC_URI = "http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-${PV}.tar.bz2 \
+           file://disable_graphite.patch \
+"
+
+SRC_URI[md5sum] = "deec04f2281bef6323f4ad1dabbf75f7"
+SRC_URI[sha256sum] = "1f8c281ded05290fd1964c0e11a2bde607713b33d0c8122a8d230452d99c2e23"
+
+inherit autotools pkgconfig
+
+DEPENDS = "icu glib-2.0 cairo freetype"
+
+BBCLASSEXTEND = "native"