]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu-config: added initscript dependencies and dropped killproc in favour of function...
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 1 Aug 2008 12:56:09 +0000 (12:56 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 1 Aug 2008 12:56:09 +0000 (12:56 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5005 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/oh/qemu-config.bb
meta/packages/oh/qemu-config/qemu-autostart

index bd5007d6f970918be1d3b374419f8b0c8d2cf3ce..f1b7de74aaf135d152b62d1094a7e8369394e9fb 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Adds scripts to use distcc on the host system under qemu"
 LICENSE = "GPL"
 RDEPENDS = "distcc task-poky-nfs-server fakeroot oprofileui-server rsync bash"
-PR = "r15"
+PR = "r16"
 
 SRC_URI = "file://distcc.sh \
            file://anjuta-remote-run \
index 5c11269389d44ece35da3bb15aa960a13196a00a..db2668eb4e03068e7e0c0c5a9b652a0f53aa09df 100755 (executable)
@@ -1,12 +1,15 @@
 #!/bin/sh
+### BEGIN INIT INFO
+# Provides:          hddtemp
+# Required-Start:    $network
+# Required-Stop:     $network
+# Default-Start:     2 3 4 5
+# Default-Stop:      0 1 6
+# Short-Description: OProfile server
+# Description:       
+### END INIT INFO
 
-killproc() {            # kill the named process(es)
-        pid=`/bin/ps -e x |
-             /bin/grep $1 |
-             /bin/grep -v grep |
-             /bin/sed -e 's/^  *//' -e 's/ .*//'`
-        [ "$pid" != "" ] && kill $pid
-}
+. /etc/init.d/functions
 
 case "$1" in
   start)