]> code.ossystems Code Review - openembedded-core.git/commitdiff
gconf: Disable gtk support
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 10 Jul 2012 13:31:33 +0000 (14:31 +0100)
committerSaul Wold <sgw@linux.intel.com>
Mon, 16 Jul 2012 15:31:40 +0000 (08:31 -0700)
There are only a couple of helper utilities within gconf that need gtk+ as a
dependency and those are unused and pretty useless. We might as well drop
the dependency on gtk and allow more parallel builds by reducing dependency
bottlenecks.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-gnome/gnome/gconf_3.2.3.bb

index ccbc24e6a4e366a2db774cc7cebf1a5052781023..1da7203fc4db38eb025c3c6ccf489e12dbbf84e3 100644 (file)
@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
 POLKIT = "polkit"
 POLKIT_libc-uclibc = ""
 
-DEPENDS = "glib-2.0 gtk+ dbus dbus-glib libxml2 intltool-native ${POLKIT}"
+DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native ${POLKIT}"
 DEPENDS_virtclass-native = "glib-2.0-native dbus-native dbus-glib-native libxml2-native intltool-native gnome-common-native"
 
-PR = "r8"
+PR = "r9"
 
 inherit gnomebase
 
@@ -26,10 +26,8 @@ POLKIT_OECONF = "--enable-defaults-service"
 POLKIT_OECONF_virtclass-native = "--disable-defaults-service"
 POLKIT_OECONF_libc-uclibc = "--disable-default-service"
 
-GTKOECONF = "--with-gtk=2.0 --enable-gtk"
-GTKOECONF_virtclass-native = "--disable-gtk"
 EXTRA_OECONF = "--disable-gtk-doc --enable-shared --disable-static --enable-debug=yes \
-                --disable-introspection --disable-orbit --with-openldap=no ${POLKIT_OECONF} ${GTKOECONF}"
+                --disable-introspection --disable-orbit --with-openldap=no ${POLKIT_OECONF} --disable-gtk"
 
 do_configure_prepend () {
        touch gtk-doc.make