]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: Backport fix for bug #123591
authorGary Thomas <gary@mlbassoc.com>
Tue, 20 Jan 2015 16:50:35 +0000 (09:50 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 23 Jan 2015 11:35:26 +0000 (11:35 +0000)
This patch fixes a crash in perl when using formatted strings @...

Signed-off-by: Gary Thomas <gary@mlbassoc.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/perl/perl-5.20.0/fix-FF_MORE-crash.patch [new file with mode: 0644]
meta/recipes-devtools/perl/perl_5.20.0.bb

diff --git a/meta/recipes-devtools/perl/perl-5.20.0/fix-FF_MORE-crash.patch b/meta/recipes-devtools/perl/perl-5.20.0/fix-FF_MORE-crash.patch
new file mode 100644 (file)
index 0000000..9ec041c
--- /dev/null
@@ -0,0 +1,21 @@
+Upstream-Status: Backport
+Reference: https://rt.perl.org/Public/Bug/Display.html?id=123591
+  From 62db6ea5fed19611596cbc5fc0b8a4df2c604e58 Mon Sep 17 00:00:00 2001
+  From: Tony Cook <tony@develop-help.com>
+  Date: Mon, 19 Jan 2015 16:03:18 +1100
+  Subject: [PATCH 1/1] [perl #123538] always set chophere and itembytes at the same time
+
+  Previously this would crash in FF_MORE because chophere was still NULL.
+
+Signed-off-by: Gary Thomas <gary@mlbassoc.com>
+Index: perl-5.20.0/pp_ctl.c
+===================================================================
+--- perl-5.20.0.orig/pp_ctl.c
++++ perl-5.20.0/pp_ctl.c
+@@ -590,6 +590,7 @@ PP(pp_formline)
+                         break;
+                 }
+                 itembytes = s - item;
++                chophere = s;
+               break;
+           }
index c1766fc3775a5221f6e0e97f37397f12e74256b8..db65202ec8e7f47e9a425d9cb0046dc2af486293 100644 (file)
@@ -63,6 +63,7 @@ SRC_URI += " \
        file://fix_bad_rpath.patch \
        file://perl-archlib-exp.patch \
        file://dynaloaderhack.patch \
+       file://fix-FF_MORE-crash.patch \
        \
         \
         file://config.sh \