]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: fix: cp command cannot find tests/Makeflie
authorJianxun Zhang <jianxun.zhang@linux.intel.com>
Thu, 8 Sep 2016 19:20:14 +0000 (12:20 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 9 Sep 2016 10:52:10 +0000 (11:52 +0100)
bitbake qemu

This error shows up:

ERROR: qemu-2.7.0-r1 do_install_ptest_base: Function failed:
do_install_ptest_base
...
cp: cannot stat '...tmp/work/core2-64-poky-linux/qemu/2.7.0-r1
/qemu-2.7.0/tests/Makefile: No such file or directory
...

Commit 46e7b70699d8bf4db08c8bb5111974318dd5416d in qemu project
renamed tests/Makefile to tests/Makefile.include, we apply the
same change in recipe accordingly to fix this issue.

Fixes [YOCTO #10245]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/qemu/qemu.inc

index d724aa4bd93e0a7fa7486c0f3823cacc23d094fb..b46e7f72e2502ce9dec941c9c66b4142f6d7fdc8 100644 (file)
@@ -76,7 +76,7 @@ do_install_ptest() {
        cp -rL ${B}/tests ${D}${PTEST_PATH}
        find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
 
-       cp ${S}/tests/Makefile ${D}${PTEST_PATH}/tests
+       cp ${S}/tests/Makefile.include ${D}${PTEST_PATH}/tests
 }
 
 do_install () {