]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg: Add the condition for the content of arch.conf when enable multilib
authorXiaofeng Yan <xiaofeng.yan@windriver.com>
Mon, 9 Apr 2012 07:16:32 +0000 (15:16 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 10 Apr 2012 12:16:00 +0000 (13:16 +0100)
After successfully installed some lib32 multilib packages into the
x86-64 image, we just found that the file content of /var/lib/opkg/status in
rootfs changed after the very 1st boot, many lib32 related packages information
are missing in that file.

The missing arch "x86" in arch.conf cause the above problem. Adding the
condition for the content of arch.conf when enable multilib. If build
multilib image, "ALL_MULTILIB_PACKAGE_ARCHS" will be used instead of
"PACKAGE_ARCHS".

[YOCTO #1522]

Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
meta/recipes-devtools/opkg/opkg-config-base_1.0.bb

index 3a559cb57d7a88761dfc39a9796cf26f659f6cdb..f37b2db27d15ff0b0cf88a2b0fe424fd664da802 100644 (file)
@@ -9,7 +9,12 @@ do_compile() {
        archconf=${S}/${sysconfdir}/opkg/arch.conf
 
        rm -f $archconf
-       ipkgarchs="${PACKAGE_ARCHS}"
+       multilibs="${@d.getVar('MULTILIBS',True)}"
+       if [ "X${multilibs}"  == "XNone" ]; then
+               ipkgarchs="${PACKAGE_ARCHS}"
+       else
+               ipkgarchs="${ALL_MULTILIB_PACKAGE_ARCHS}"
+       fi
        priority=1
        for arch in $ipkgarchs; do 
                echo "arch $arch $priority" >> $archconf