]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcc-source: fix bug to avoid building error.
authorBian Naimeng <biannm@cn.fujitsu.com>
Mon, 2 Mar 2015 11:34:48 +0000 (19:34 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 9 Mar 2015 16:00:15 +0000 (16:00 +0000)
gcc-source don't do do_package_write_rpm, so we should set
PACKAGES = "" to avoid the building error if we want generate srpm,
otherwise, we get the error as below.

ERROR: Task do_deploy_archives in meta/recipes-devtools/gcc/gcc-source_4.9.bb \
       depends upon non-existent task do_package_write_rpm in \
       meta/recipes-devtools/gcc/gcc-source_4.9.bb

Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/gcc/gcc-source.inc

index 968830aa35a025b87b9940fa1a6abb6973bda6d4..10e9285c44389450b31b7cb2c6560cef44867855 100644 (file)
@@ -19,6 +19,7 @@ STAMPCLEAN = "${STAMPS_DIR}/work-shared/gcc-[0-9]*-*"
 
 INHIBIT_DEFAULT_DEPS = "1"
 DEPENDS = ""
+PACKAGES = ""
 
 python do_preconfigure () {
     import subprocess