]> code.ossystems Code Review - openembedded-core.git/commitdiff
distcc: Fix remaining postinst issues
authorRichard Purdie <richard@openedhand.com>
Wed, 28 Nov 2007 15:58:35 +0000 (15:58 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 28 Nov 2007 15:58:35 +0000 (15:58 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3263 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/distcc/distcc_2.18.3.bb

index d52f696cb3c31b18c7f87c1565344c102c9779ef..82f45e61c209af004a7fddd7758180c432ff8e2f 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "distcc is a parallel build system that distributes \
 compilation of C/C++/ObjC code across machines on a network."
 SECTION = "devel"
 LICENSE = "GPLv2"
-PR = "r2"
+PR = "r3"
 
 DEPENDS = "avahi gtk+"
 RRECOMMENDS = "avahi-daemon"
@@ -34,11 +34,11 @@ FILES_${PN} = " ${sysconfdir} \
 FILES_distcc-distmon-gnome = "  ${bindir}/distccmon-gnome \
                                ${datadir}/distcc"
 
-pkg_postinst() {
+pkg_postinst_${PN} () {
        if test "x$D" != "x"; then
                exit 1
        else
-               grep distcc /etc/passwd || adduser --system --home /dev/null --empty-password --ingroup nogroup distcc
+               grep distcc /etc/passwd || adduser --system --home /dev/null --no-create-home --empty-password --ingroup nogroup distcc
        fi
 }