]> code.ossystems Code Review - openembedded-core.git/commitdiff
layer.conf: allow other layers to depend on this version
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Tue, 25 Sep 2012 14:58:32 +0000 (15:58 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 26 Sep 2012 13:54:53 +0000 (14:54 +0100)
Set LAYERVERSION and rename the collection to "core". Given changes such
as the tabs to spaces cleanup for python functions in the current
version, this allows other layers to depend on this version of OE-Core
specifically should they choose to do so, by specifying the following
in their own layer.conf:

LAYERDEPENDS_layername = "core:1"

Where layername is whatever value is being added to BBFILE_COLLECTIONS.

(This change does nothing unless a layer has LAYERDEPENDS set.)

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/layer.conf

index ed50f1c509fa8d5c1595736689c9889642353314..78ceae9db6669012f158d786c8d45ec860c8001c 100644 (file)
@@ -3,9 +3,13 @@ BBPATH .= ":${LAYERDIR}"
 # We have a packages directory, add to BBFILES
 BBFILES += "${LAYERDIR}/recipes-*/*/*.bb"
 
-BBFILE_COLLECTIONS += "normal"
-BBFILE_PATTERN_normal := "^${LAYERDIR}/"
-BBFILE_PRIORITY_normal = "5"
+BBFILE_COLLECTIONS += "core"
+BBFILE_PATTERN_core := "^${LAYERDIR}/"
+BBFILE_PRIORITY_core = "5"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_core = "1"
 
 # Set a variable to get to the top of the metadata location
 COREBASE := '${@os.path.normpath("${LAYERDIR}/../")}'