]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: make coredump a PACKAGECONFIG
authorDaniel McGregor <daniel.mcgregor@vecima.com>
Tue, 3 Nov 2015 22:54:36 +0000 (16:54 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 25 Nov 2015 08:01:32 +0000 (08:01 +0000)
Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/systemd/systemd_225.bb

index 6393ca0fef5cca08a8da39b807f6860b1fa42950..20391d773a9e5d346bdb52312e46e29596a02130 100644 (file)
@@ -93,6 +93,7 @@ PACKAGECONFIG[valgrind] = "ac_cv_header_valgrind_memcheck_h=yes ac_cv_header_val
 PACKAGECONFIG[qrencode] = "--enable-qrencode,--disable-qrencode,qrencode"
 PACKAGECONFIG[compat] = "--enable-compat-libs,--disable-compat-libs"
 PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
+PACKAGECONFIG[coredump] = "--enable-coredump,--disable-coredump"
 
 CACHED_CONFIGUREVARS += "ac_cv_path_KILL=${base_bindir}/kill"
 CACHED_CONFIGUREVARS += "ac_cv_path_KMOD=${base_bindir}/kmod"
@@ -120,7 +121,6 @@ CACHED_CONFIGUREVARS_class-target = "\
 EXTRA_OECONF = " --with-rootprefix=${rootprefix} \
                  --with-rootlibdir=${rootlibdir} \
                  --with-roothomedir=${ROOT_HOME} \
-                 --disable-coredump \
                  --enable-split-usr \
                  --without-python \
                  --with-sysvrcnd-path=${sysconfdir} \
@@ -271,6 +271,7 @@ RRECOMMENDS_${PN}-binfmt = "kernel-module-binfmt-misc"
 RRECOMMENDS_${PN}-vconsole-setup = "kbd kbd-consolefonts kbd-keymaps"
 
 CONFFILES_${PN} = "${sysconfdir}/machine-id \
+                ${sysconfdir}/systemd/coredump.conf \
                 ${sysconfdir}/systemd/journald.conf \
                 ${sysconfdir}/systemd/logind.conf \
                 ${sysconfdir}/systemd/system.conf \
@@ -300,6 +301,7 @@ FILES_${PN} = " ${base_bindir}/* \
                 /cgroup \
                 ${bindir}/systemd* \
                 ${bindir}/busctl \
+                ${bindir}/coredumpctl \
                 ${bindir}/localectl \
                 ${bindir}/hostnamectl \
                 ${bindir}/timedatectl \