]> code.ossystems Code Review - openembedded-core.git/commitdiff
Set gconf key for theme name on install
authorRoss Burton <ross@openedhand.com>
Fri, 14 Oct 2005 08:54:23 +0000 (08:54 +0000)
committerRoss Burton <ross@openedhand.com>
Fri, 14 Oct 2005 08:54:23 +0000 (08:54 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@137 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/matchbox-poky/matchbox-poky_0.1.bb

index 12febdb31ba52782676405d5d3c95c8c370e3fc6..72024355e6f9af8d55785d21e26506c329ed2fd5 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Custom MB session files for poky"
 LICENSE = "GPL"
 SECTION = "x11"
 RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-theme-clearlooks"
-PR = "r10"
+PR = "r11"
 
 SRC_URI = "file://etc"
 S = ${WORKDIR}
@@ -11,3 +11,8 @@ do_install() {
        cp -R ${S}/etc ${D}/etc
        chmod -R 755 ${D}/etc
 }
+
+pkg_postinst_matchbox-poky () {
+#!/bin/sh -e
+gconftool --config-source=xml::${IMAGE_ROOTFS}/${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/theme Clearlooks
+}