]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto-dev: update to v4.15+
authorBruce Ashfield <bruce.ashfield@windriver.com>
Thu, 21 Dec 2017 15:49:18 +0000 (10:49 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Dec 2017 16:26:36 +0000 (16:26 +0000)
Outside of the normal patch refreshes and boot issues, there are new
build time tools within the kernel that required the following
dependencies:

For ORC_UNWINDER support in x86-64:

 DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"

And for certificate processing during the build, we need ssl headers
and hexdump:

  DEPENDS += "openssl-native util-linux-native"

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-dev.bb

index 6876ab707153e2e4afbce87bf37e7a844a6fed1a..490b83af6842f28ec8232724803082676b980224 100644 (file)
@@ -28,10 +28,13 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-dev.git;branch=${KBRANCH};name
 SRCREV_machine ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}'
 SRCREV_meta ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "linux-yocto-dev", "${AUTOREV}", "29594404d7fe73cd80eaa4ee8c43dcc53970c60e", d)}'
 
-LINUX_VERSION ?= "4.14-rc+"
+LINUX_VERSION ?= "4.15-rc+"
 LINUX_VERSION_EXTENSION ?= "-yoctodev-${LINUX_KERNEL_TYPE}"
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
+DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
+DEPENDS += "openssl-native util-linux-native"
+
 COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64)"
 
 KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"