]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-firmware: fix permissions of installed files
authorAndreas Oberritter <obi@opendreambox.org>
Sat, 10 Mar 2012 02:31:26 +0000 (03:31 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 13 Mar 2012 11:44:46 +0000 (11:44 +0000)
* The previous copy command preserved the original
  owner and permission bits.
* The new command uses root:root and applies OE's
  umask.

Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
meta/recipes-kernel/linux-firmware/linux-firmware_git.bb

index a99dc7e171565a62933b9a63c7451087dfe4019a..52929fa38b32039dabbca49971fd946e1f2cf1dc 100644 (file)
@@ -21,7 +21,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.radeon_rlc;md5=4c243f7854d2884b483abda991adef
 
 SRCREV = "15888a2eab052ac3d3f49334e4f6f05f347a516e"
 PV = "0.0+git${SRCPV}"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "git://git.infradead.org/users/dwmw2/linux-firmware.git;protocol=git"
 
@@ -35,7 +35,7 @@ do_compile() {
 
 do_install() {
        install -d  ${D}/lib/firmware/
-       cp -RpP * ${D}/lib/firmware/
+       cp -r * ${D}/lib/firmware/
 
        # Libertas sd8686
        install -m 0644 libertas/sd8686_v9.bin ${D}/lib/firmware/sd8686.bin