]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: remove useless options for mips4
authorChen Qi <Qi.Chen@windriver.com>
Fri, 27 Oct 2017 09:43:50 +0000 (17:43 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 8 Nov 2017 22:23:44 +0000 (22:23 +0000)
Looking back the history, we had problem with systemd on qemumips64
which is also related to compilation flags. We solved that by using
tweaking FULL_OPTIMIZATION for mips64 to have "-fno-tree-switch-conversion
-fno-tree-tail-merge".

Now systemd has been upgraded to 234, and we don't have the above problem
any more, thus removing these flags.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/systemd/systemd_234.bb

index 36fd3f8ff4bd10656777f141e9c0b4245dd2919f..971226ff7c8e8bae3d532f99fef274260914ea83 100644 (file)
@@ -158,9 +158,6 @@ CFLAGS .= "${@bb.utils.contains('PACKAGECONFIG', 'valgrind', ' -DVALGRIND=1', ''
 # disable problematic GCC 5.2 optimizations [YOCTO #8291]
 FULL_OPTIMIZATION_append_arm = " -fno-schedule-insns -fno-schedule-insns2"
 
-# Avoid login failure on qemumips64 when pam is enabled
-FULL_OPTIMIZATION_append_mips64 = " -fno-tree-switch-conversion -fno-tree-tail-merge"
-
 COMPILER_NM ?= "${HOST_PREFIX}gcc-nm"
 COMPILER_AR ?= "${HOST_PREFIX}gcc-ar"
 COMPILER_RANLIB ?= "${HOST_PREFIX}gcc-ranlib"