]> code.ossystems Code Review - openembedded-core.git/commitdiff
Fix sat-solver & RPM5 integration issue
authorMark Hatle <mark.hatle@windriver.com>
Tue, 29 Mar 2011 03:05:18 +0000 (22:05 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 31 Mar 2011 14:33:01 +0000 (15:33 +0100)
From Michael Schroeder, fix the configuration of how RPM5 handles obsoletes
within the sat-solver.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-extended/sat-solver/sat-solver/sat-solver_obsolete.patch [new file with mode: 0644]
meta/recipes-extended/sat-solver/sat-solver_git.bb

diff --git a/meta/recipes-extended/sat-solver/sat-solver/sat-solver_obsolete.patch b/meta/recipes-extended/sat-solver/sat-solver/sat-solver_obsolete.patch
new file mode 100644 (file)
index 0000000..7685057
--- /dev/null
@@ -0,0 +1,20 @@
+Fix obsolete settings with RPM5.
+
+The following patch is from Michael Schroeder <mls@suse.de>
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff -ur git.orig/src/pool.c git/src/pool.c
+--- git.orig/src/pool.c        2011-03-25 15:49:34.885834194 -0500
++++ git/src/pool.c     2011-03-28 10:55:13.138786524 -0500
+@@ -70,6 +70,10 @@
+   pool->disttype = DISTTYPE_DEB;
+ # endif
+ #endif
++#ifdef RPM5
++  pool->obsoleteusesprovides = 1;
++  pool->implicitobsoleteusesprovides = 1;
++#endif
+   return pool;
+ }
index ba5af67f702613dc8171f2de1bdc58f8f1727a27..33bf9392e2437bf434b60f132cfd0a2abb3653fb 100644 (file)
@@ -7,10 +7,11 @@ LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
 DEPENDS = "libcheck rpm zlib expat db"
 
 PV = "0.0-git${SRCPV}"
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "git://gitorious.org/opensuse/sat-solver.git;protocol=git \
            file://sat-solver_rpm5.patch \
+           file://sat-solver_obsolete.patch \
            file://cmake.patch \
            file://db5.patch \
            file://builtin-arch.patch;apply=no \