]> code.ossystems Code Review - openembedded-core.git/commitdiff
connman: Initial poky commit
authorSamuel Ortiz <sameo@openedhand.com>
Mon, 22 Sep 2008 19:02:30 +0000 (19:02 +0000)
committerSamuel Ortiz <sameo@openedhand.com>
Mon, 22 Sep 2008 19:02:30 +0000 (19:02 +0000)
We're adding both connman the daemon and connman-gnome which is a gnome
applet.

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5225 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/conf/distro/include/poky-fixed-revisions.inc
meta/packages/connman/connman-gnome_git.bb [new file with mode: 0644]
meta/packages/connman/connman_git.bb [new file with mode: 0644]
meta/packages/connman/files/connman [new file with mode: 0755]

index b239af2aeb74a248c629b06c3f34e9f270d11ff0..4fe7cd337453dbec96863e5345880260e13f5f72 100644 (file)
@@ -24,6 +24,8 @@ SRCREV_pn-clutter-box2d = "3197"
 SRCREV_pn-clutter-cairo ?= "3210"
 SRCREV_pn-clutter-gst ?= "3188"
 SRCREV_pn-clutter ?= "3240"
+SRCREV_pn-connman ?= "e952851502277cc41cd2a54ef5386cca7a8843dd"
+SRCREV_pn-connman-gnome ?= "b589f4f89bff20d54682cc6b49efa86feac8adb4"
 SRCREV_pn-dbus-wait ?= "402"
 SRCREV_pn-eds-dbus ?= "691"
 SRCREV_pn-evince ?= "2437"
diff --git a/meta/packages/connman/connman-gnome_git.bb b/meta/packages/connman/connman-gnome_git.bb
new file mode 100644 (file)
index 0000000..59c5675
--- /dev/null
@@ -0,0 +1,16 @@
+HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php"
+SUMMARY  = "Moblin Glib D-Bus integration"
+LICENSE  = "GPL LGPL"
+PV       = "0.0+git${SRCREV}"
+S        = "${WORKDIR}/git"
+
+RDEPENDS  = "connman"
+
+SRC_URI  = "git://moblin.org/repos/projects/connman-gnome.git;protocol=http"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "${datadir}/icons/hicolor/22x22/apps \
+               ${bindir}/* \
+               ${top_builddir}/common \
+               ${sysconfdir}/xdg "
diff --git a/meta/packages/connman/connman_git.bb b/meta/packages/connman/connman_git.bb
new file mode 100644 (file)
index 0000000..e8ad21e
--- /dev/null
@@ -0,0 +1,48 @@
+HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php"
+SUMMARY  = "Moblin Connection Manager"
+PV       = "0.0+git${SRCREV}"
+PR       = "r4"
+S        = "${WORKDIR}/git"
+LICENSE  = "GPL"
+
+DEPENDS  = "libgdbus dbus glib-2.0 hal"
+RDEPENDS = "dhcp-client wpa-supplicant resolvconf"
+
+EXTRA_OECONF += " \
+    ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant \
+    ac_cv_path_DHCLIENT=/sbin/dhclient "
+
+SRC_URI  = "git://moblin.org/repos/projects/connman.git;protocol=http \
+            file://connman "
+
+INITSCRIPT_NAME = "connman"
+INITSCRIPT_PARAMS = "defaults 22"
+
+inherit autotools pkgconfig update-rc.d
+
+do_install_append() {
+    install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
+}
+
+PACKAGES_DYNAMIC = "${PN}-plugin-*"
+PACKAGES += "${PN}-script-dhclient"
+FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*.so.* \
+            ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+            ${base_bindir}/* ${base_sbindir}/* ${base_libdir}/*.so* ${datadir}/${PN} \
+            ${datadir}/pixmaps ${datadir}/applications \
+            ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
+            ${libdir}/bonobo/servers \
+            ${datadir}/dbus-1/system-services/*"
+FILES_${PN}-script-dhclient += "${libdir}/connman/scripts/dhclient*"
+FILES_${PN}-dbg += "${libdir}/connman/plugins/.debug \
+                    ${libdir}/connman/scripts/.debug"
+
+python populate_packages_prepend() {
+       plugin_dir = bb.data.expand('${libdir}/connman/plugins/', d)
+       plugin_name = bb.data.expand('${PN}-plugin-%s', d)
+       do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='' )
+}
+
+do_stage() {
+    autotools_stage_all
+}
diff --git a/meta/packages/connman/files/connman b/meta/packages/connman/files/connman
new file mode 100755 (executable)
index 0000000..5e0f90e
--- /dev/null
@@ -0,0 +1,42 @@
+#!/bin/sh
+
+DAEMON=/usr/sbin/connmand
+PIDFILE=/var/run/connmand.pid
+DESC="Connection Manager"
+
+if [ -f /etc/default/connman ] ; then
+       . /etc/default/connman
+fi
+
+set -e
+
+do_start() {
+       connmand 
+}
+
+do_stop() {
+       start-stop-daemon --stop --name connmand --quiet
+}
+
+case "$1" in
+  start)
+       echo "Starting $DESC"
+       do_start
+       ;;
+  stop)
+       echo "Stopping $DESC"
+       do_stop
+       ;;
+  restart|force-reload)
+       echo "Restarting $DESC"
+       do_stop
+       sleep 1
+       do_start
+       ;;
+  *)
+       echo "Usage: $0 {start|stop|restart|force-reload}" >&2
+       exit 1
+       ;;
+esac
+
+exit 0