]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: obey LDFLAGS
authorChristopher Larson <chris_larson@mentor.com>
Wed, 3 Sep 2014 16:42:54 +0000 (09:42 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 22 Sep 2014 11:57:12 +0000 (12:57 +0100)
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
meta/recipes-devtools/python/python_2.7.3.bb

index 58bccedb8fa87a0ce409984fb73e187859ed39be..d93bc64dbf0ab14df81dd65d6e4b0c5537edf238 100644 (file)
@@ -75,7 +75,7 @@ do_compile() {
        if [ ! -f Makefile.orig ]; then
                install -m 0644 Makefile Makefile.orig
        fi
-       sed -i -e 's,^LDFLAGS=.*,LDFLAGS=-L. -L${STAGING_LIBDIR},g' \
+       sed -i -e 's#^LDFLAGS=.*#LDFLAGS=${LDFLAGS} -L. -L${STAGING_LIBDIR}#g' \
                -e 's,libdir=${libdir},libdir=${STAGING_LIBDIR},g' \
                -e 's,libexecdir=${libexecdir},libexecdir=${STAGING_DIR_HOST}${libexecdir},g' \
                -e 's,^LIBDIR=.*,LIBDIR=${STAGING_LIBDIR},g' \