]> code.ossystems Code Review - openembedded-core.git/commitdiff
puzzles: split into oh-puzzles and oh-puzzles-extra, so there is a reasonable number...
authorRoss Burton <ross@openedhand.com>
Mon, 25 Feb 2008 22:47:49 +0000 (22:47 +0000)
committerRoss Burton <ross@openedhand.com>
Mon, 25 Feb 2008 22:47:49 +0000 (22:47 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3864 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/puzzles/oh-puzzles_svn.bb

index f75cf46a09cebc142137671de6bc9f62b41b8b0e..a58468792930a2bdb9f5b88018dee4f85cdb1d98 100644 (file)
@@ -2,8 +2,9 @@ DESCRIPTION = "Portable Puzzle Collection"
 LICENSE = "MIT"
 SECTION = "x11"
 DEPENDS = "gtk+ gconf intltool-native librsvg"
+
 PV = "0.1+svnr${SRCREV}"
-PR = "r5"
+PR = "r6"
 
 bindir = "/usr/games"
 
@@ -40,5 +41,20 @@ STOP
     done
 }
 
-FILES_${PN} += "/usr/games/*"
+PACKAGES += ${PN}-extra
+RDEPENDS_${PN}-extra += "oh-puzzles"
+
+FILES_${PN} = "/usr/share/pixmaps /usr/share/oh-puzzles/"
 FILES_${PN}-dbg += "/usr/games/.debug/*"
+FILES_${PN}-extra = "/usr/games/ /usr/share/applications /etc/gconf/schemas"
+
+python __anonymous () {
+    import bb
+    var = bb.data.expand("FILES_${PN}", d, 1)
+    data = bb.data.getVar(var, d, 1)
+    for name in ("bridges", "fifteen", "inertia", "map", "mines", "samegame"):
+        data = data + " /usr/games/%s" % name
+        data = data + " /usr/share/applications/%s.desktop" % name
+        data = data + " /etc/gconf/schemas/%s.schemas" % name
+    bb.data.setVar(var, data, d)
+}
\ No newline at end of file