]> code.ossystems Code Review - openembedded-core.git/commitdiff
irda-utils_0.9.18.bb: Fix recipe metadata
authorDongxiao Xu <dongxiao.xu@intel.com>
Fri, 25 Jun 2010 07:33:23 +0000 (15:33 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 30 Jun 2010 12:12:54 +0000 (13:12 +0100)
Fix LICENSE information
Add HOMEPAGE, BUGTRACKER, and LIC_FILES_CHKSUM
Use blank space to replace the tab

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
meta/packages/irda-utils/irda-utils_0.9.18.bb

index 25be0fe84df7b5ef98d766fd0891885efb29a888..9ef8a59fb40f797867faa63276ad6d877580dff5 100644 (file)
@@ -1,12 +1,18 @@
 DESCRIPTION = "Provides common files needed to use IrDA. \
 IrDA allows communication over Infrared with other devices \
 such as phones and laptops."
+HOMEPAGE = "http://irda.sourceforge.net/"
+BUGTRACKER = "irda-users@lists.sourceforge.net"
 SECTION = "base"
-LICENSE = "GPL"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://irdadump/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+                    file://smcinit/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
+                    file://man/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+                    file://irdadump/irdadump.c;beginline=1;endline=24;md5=d78b9dce3cd78c2220250c9c7a2be178"
 PR = "r0"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/irda/irda-utils-${PV}.tar.gz \
-          file://init"
+          file://init"
 
 export SYS_INCLUDES="-I${STAGING_INCDIR}"
 
@@ -16,8 +22,8 @@ INITSCRIPT_NAME = "irattach"
 INITSCRIPT_PARAMS = "defaults 20"
 
 do_compile () {
-       oe_runmake -e -C irattach
-       oe_runmake -e -C irdaping
+    oe_runmake -e -C irattach
+    oe_runmake -e -C irdaping
 }
 
 do_install () {