]> code.ossystems Code Review - openembedded-core.git/commitdiff
ltp: fix test_proc_kill hanging
authorTudor Florea <tudor.florea@enea.com>
Fri, 1 Apr 2016 11:46:20 +0000 (13:46 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 1 Apr 2016 14:02:21 +0000 (15:02 +0100)
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/ltp/ltp/0035-fix-test_proc_kill-hang.patch [new file with mode: 0644]
meta/recipes-extended/ltp/ltp_20160126.bb

diff --git a/meta/recipes-extended/ltp/ltp/0035-fix-test_proc_kill-hang.patch b/meta/recipes-extended/ltp/ltp/0035-fix-test_proc_kill-hang.patch
new file mode 100644 (file)
index 0000000..32ae8aa
--- /dev/null
@@ -0,0 +1,23 @@
+Fix test_proc_kill hanging
+
+Sometimes the signal is delivered to memcg_process before the framework took
+into consideration its pid entered in the tasks. Fixed by delaying the signal
+send command.
+
+Signed-off-by: George Nita <george.nita@enea.com>
+Upstream-Status: Pending 
+
+diff --git a/testcases/kernel/controllers/memcg/functional/memcg_lib.sh b/testcases/kernel/controllers/memcg/functional/memcg_lib.sh
+index ffbe006..e81bf74 100755
+--- a/testcases/kernel/controllers/memcg/functional/memcg_lib.sh
++++ b/testcases/kernel/controllers/memcg/functional/memcg_lib.sh
+@@ -220,8 +220,8 @@ test_proc_kill()
+       $TEST_PATH/memcg_process $2 -s $3 &
+       pid=$!
+-      sleep 1
+       echo $pid > tasks
++      sleep 1
+       kill -s USR1 $pid 2> /dev/null
+       sleep 1
index 6be2187eaa0a26d3a91858d7b5ed29186e2daddc..097c16d5709e79a75db697aee5d4a5a6de4415e0 100644 (file)
@@ -61,6 +61,7 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
            file://0032-regen.sh-Include-asm-unistd.h-explicitly.patch \
            file://0033-shmat1-Cover-GNU-specific-code-under-__USE_GNU.patch \
            file://0034-periodic_output.patch \
+           file://0035-fix-test_proc_kill-hang.patch \
            "
 
 S = "${WORKDIR}/git"