]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-mako: add a Python 3 recipe
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Wed, 11 May 2016 13:36:37 +0000 (16:36 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 1 Jun 2016 07:04:11 +0000 (08:04 +0100)
This will be necessary for transiting piglit to Python 3.
Python 2 recipe should be kept as it is used by mesa (and
gobject-introspection, for now).

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
meta/recipes-devtools/python/python-mako_1.0.3.bb
meta/recipes-devtools/python/python3-mako_1.0.3.bb [new file with mode: 0644]

index 9efd700dc065d0a1a857942f8439ad064494888f..d4f426dadd859be78b6bd33593395741fe1b8092 100644 (file)
@@ -22,3 +22,9 @@ RDEPENDS_${PN} = "python-threading \
 RDEPENDS_${PN}_class-native = ""
 
 BBCLASSEXTEND = "native nativesdk"
+
+# The same utility is packaged in python3-mako, so it would conflict
+do_install_append() {
+    rm -f ${D}${bindir}/mako-render
+    rm -df ${D}${bindir}
+}
diff --git a/meta/recipes-devtools/python/python3-mako_1.0.3.bb b/meta/recipes-devtools/python/python3-mako_1.0.3.bb
new file mode 100644 (file)
index 0000000..c770603
--- /dev/null
@@ -0,0 +1,24 @@
+SUMMARY = "Templating library for Python"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=deb3ff8e4c17aaf7b80889b6b2bf4c83"
+
+SRC_URI = "https://pypi.python.org/packages/source/M/Mako/Mako-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "a78f20f6366a8a0659ce5532f8614e53"
+SRC_URI[sha256sum] = "7644bc0ee35965d2e146dde31827b8982ed70a58281085fac42869a09764d38c"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/mako/"
+UPSTREAM_CHECK_REGEX = "/Mako/(?P<pver>(\d+[\.\-_]*)+)"
+
+S = "${WORKDIR}/Mako-${PV}"
+
+inherit setuptools3
+
+RDEPENDS_${PN} = "python3-threading \
+                  python3-netclient \
+                  python3-html \
+"
+RDEPENDS_${PN}_class-native = ""
+
+BBCLASSEXTEND = "native nativesdk"