]> code.ossystems Code Review - openembedded-core.git/commitdiff
libsdl2: disable sndio explicitly to avoid inconsistent result
authorChen Qi <Qi.Chen@windriver.com>
Sat, 29 Sep 2018 06:13:30 +0000 (14:13 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 1 Oct 2018 12:04:44 +0000 (13:04 +0100)
Explicitly disable sndio to avoid inconsistent result on different
hosts having or not having libsndio.

This must be done if we take into consideration of eSDK.

I built eSDK on Ubuntu 14.04 which has libsndio installed, and then
installed the eSDK on Fedora 27, which does not have libsndio. In
fact, on Fedora 27, I even cannot find libsndio in its repo.

The problem happens when trying to use `devtool runqemu'. The qemu
binary built on Ubuntu 14.04 needs to link to libsndio, and thus
the following error.

  runqemu - ERROR - Failed to run qemu: /path/to/qemu-system-x86_64:
            error while loading shared libraries: libsndio.so.6.1:
            cannot open shared object file: No such file or directory

So explicitly disable sndio for libsdl2 to avoid the above problem.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/libsdl2/libsdl2_2.0.8.bb

index 52bb93a17aeaac043a4ee42cf6523f0fedafd1fa..812a9abf3c86efc2ca01487652301f8a672e932d 100644 (file)
@@ -30,6 +30,7 @@ EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \
                 --enable-pthreads \
                 --enable-sdl-dlopen \
                 --disable-rpath \
+                --disable-sndio \
                 "
 
 # opengl packageconfig factored out to make it easy for distros