]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add opkg-utils
authorRichard Purdie <richard@openedhand.com>
Thu, 17 Jul 2008 21:32:43 +0000 (21:32 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 17 Jul 2008 21:32:43 +0000 (21:32 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4862 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/opkg-utils/opkg-utils-native_svn.bb [new file with mode: 0644]
meta/packages/opkg-utils/opkg-utils/opkg-utils.tgz [new file with mode: 0644]
meta/packages/opkg-utils/opkg-utils_svn.bb [new file with mode: 0644]

diff --git a/meta/packages/opkg-utils/opkg-utils-native_svn.bb b/meta/packages/opkg-utils/opkg-utils-native_svn.bb
new file mode 100644 (file)
index 0000000..0495b1e
--- /dev/null
@@ -0,0 +1,10 @@
+require opkg-utils_svn.bb
+
+RDEPENDS = ""
+
+inherit native
+
+# Avoid circular dependencies from package_ipk.bbclass
+PACKAGES = ""
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/opkg-utils"
+
diff --git a/meta/packages/opkg-utils/opkg-utils/opkg-utils.tgz b/meta/packages/opkg-utils/opkg-utils/opkg-utils.tgz
new file mode 100644 (file)
index 0000000..50525d1
Binary files /dev/null and b/meta/packages/opkg-utils/opkg-utils/opkg-utils.tgz differ
diff --git a/meta/packages/opkg-utils/opkg-utils_svn.bb b/meta/packages/opkg-utils/opkg-utils_svn.bb
new file mode 100644 (file)
index 0000000..12a8c9d
--- /dev/null
@@ -0,0 +1,16 @@
+DESCRIPTION = "OPKG Package Manager Utilities"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "python"
+PR = "r1"
+
+SRC_URI = "file://opkg-utils.tgz"
+
+inherit autotools
+
+S = "${WORKDIR}/opkg-utils"
+
+do_stage () {
+       autotools_stage_all
+}