]> code.ossystems Code Review - openembedded-core.git/commitdiff
valgrind: enable building on 4.x kernel
authorMartin Jansa <martin.jansa@gmail.com>
Mon, 20 Apr 2015 12:37:34 +0000 (14:37 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 20 Apr 2015 14:31:29 +0000 (15:31 +0100)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/valgrind/valgrind/enable.building.on.4.x.kernel.patch [new file with mode: 0644]
meta/recipes-devtools/valgrind/valgrind_3.9.0.bb

diff --git a/meta/recipes-devtools/valgrind/valgrind/enable.building.on.4.x.kernel.patch b/meta/recipes-devtools/valgrind/valgrind/enable.building.on.4.x.kernel.patch
new file mode 100644 (file)
index 0000000..a90fcc5
--- /dev/null
@@ -0,0 +1,36 @@
+Enable building valgrind on host with 4.x kernel.
+
+For OpenEmbedded builds we should be checking something like
+OLDEST_KERNEL instead of `uname -r`, but this is good enough for now.
+
+Building on 4.x* currently fails with:
+  configure:5556: checking for the kernel version
+  configure:5579: result: unsupported (4.0.0-rc3-00111-gaffb817)
+  configure:5581: error: Valgrind works on kernels 2.4, 2.6
+
+Upstream-Status: Pending
+
+--- valgrind-3.9.0/configure.ac.orig   2015-03-13 19:17:01.247310868 +0100
++++ valgrind-3.9.0/configure.ac        2015-03-13 19:19:27.388316108 +0100
+@@ -276,9 +276,9 @@
+         kernel=`uname -r`
+         case "${kernel}" in
+-             2.6.*|3.*) 
+-                  AC_MSG_RESULT([2.6.x/3.x family (${kernel})])
+-                  AC_DEFINE([KERNEL_2_6], 1, [Define to 1 if you're using Linux 2.6.x or Linux 3.x])
++             2.6.*|3.*|4.*) 
++                  AC_MSG_RESULT([2.6.x/3.x/4.x family (${kernel})])
++                  AC_DEFINE([KERNEL_2_6], 1, [Define to 1 if you're using Linux 2.6.x or Linux 3.x or Linux 4.x])
+                   ;;
+              2.4.*) 
+@@ -288,7 +288,7 @@
+              *) 
+                   AC_MSG_RESULT([unsupported (${kernel})])
+-                  AC_MSG_ERROR([Valgrind works on kernels 2.4, 2.6])
++                  AC_MSG_ERROR([Valgrind works on kernels 2.4, 2.6, 3.x, 4.x])
+                   ;;
+         esac
index eea81a2405beff4fe8361227bdef5a6569e73679..9e1ab5f201dbbc450b1cfb4ab5e23bc65298b28a 100644 (file)
@@ -19,6 +19,7 @@ SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
            file://force-nostabs.patch \
            file://remove-arm-variant-specific.patch \
            file://remove-ppc-tests-failing-build.patch \
+           file://enable.building.on.4.x.kernel.patch \
            file://add-ptest.patch \
            file://pass-maltivec-only-if-it-supported.patch \
            file://run-ptest \