]> code.ossystems Code Review - openembedded-core.git/commitdiff
ghostscript: disable check for time.h
authorJoshua Lock <joshual@takoba.(none)>
Tue, 27 Sep 2011 19:53:34 +0000 (12:53 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 28 Sep 2011 10:47:23 +0000 (11:47 +0100)
ghostscript has it's own hacky check for time.h which hard-codes paths, this
means in the native case it fails on systems such as Ubuntu 11.10 where the
location of time.h has changed. Further it means the target build has had a
host-intrusion issue.

This patch disables the check for time.h, future releases of ghostscript
use standard autotools checks for time.h's location.

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/recipes-extended/ghostscript/ghostscript_9.02.bb

index 2e467341efc1637b571694ae11814f17d77970bd..9b21c669562b54be23b52ef4629264601406e7d6 100644 (file)
@@ -36,6 +36,11 @@ SRC_URI[sha256sum] = "03ea2cad13a36f8f9160912012b79619a826e7148fada6d3531feb2540
 
 EXTRA_OECONF = "--without-x --with-system-libtiff --without-jbig2dec --without-jasper --with-fontpath=${datadir}/fonts"
 
+# This has been fixed upstream but for now we need to subvert the check for time.h
+# http://bugs.ghostscript.com/show_bug.cgi?id=692443
+# http://bugs.ghostscript.com/show_bug.cgi?id=692426
+CFLAGS += "-DHAVE_SYS_TIME_H=1"
+
 inherit autotools
 
 do_configure () {