]> code.ossystems Code Review - openembedded-core.git/commitdiff
puzzles: Fix packaging
authorRichard Purdie <richard@openedhand.com>
Sun, 29 Oct 2006 09:54:31 +0000 (09:54 +0000)
committerRichard Purdie <richard@openedhand.com>
Sun, 29 Oct 2006 09:54:31 +0000 (09:54 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@834 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/puzzles/puzzles_r6727.bb

index c3725ac8f7f559ea0c4a6941d855e5b3897c4078..f8ffcb7d011858a2aa6ec75ae994235a80711701 100644 (file)
@@ -10,19 +10,21 @@ do_compile_prepend = " \
        export CFLAGS='${CFLAGS} -I./ `${STAGING_BINDIR}/pkg-config gtk+-2.0 --cflags`'; "
 
 FILES_${PN} = "${prefix}/games/* ${datadir}/applications/* ${datadir}/pixmaps"
+FILES_${PN}-dbg += "${prefix}/games/.debug"
 
 do_install () {
+    rm -rf ${D}/*
     export prefix=${D}
     export DESTDIR=${D}
-    install -d ${D}/${prefix}
-    install -d ${D}/${prefix}/games
+    install -d ${D}/${prefix}/
+    install -d ${D}/${prefix}/games/
     oe_runmake install
     
-    install -d ${D}/${datadir}
-    install -d ${D}/${datadir}/applications
-    install -d ${D}/${datadir}/pixmaps
+    install -d ${D}/${datadir}/
+    install -d ${D}/${datadir}/applications/
+    install -d ${D}/${datadir}/pixmaps/
 
-    install ${WORKDIR}/game.png ${D}/${datadir}/pixmaps
+    install ${WORKDIR}/game.png ${D}/${datadir}/pixmaps/
 
     cd ${D}/${prefix}/games 
     for prog in *; do