]> code.ossystems Code Review - openembedded-core.git/commitdiff
trace-cmd: Update to 1.2 (includes kernelshark)
authorDarren Hart <dvhart@linux.intel.com>
Thu, 1 Dec 2011 01:58:52 +0000 (17:58 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 1 Dec 2011 10:49:14 +0000 (10:49 +0000)
Update the trace-cmd and kernelshark recipes to version 1.2. Rename the recipes
to the more descriptive trace-cmd_1.2.bb and kernelshark_1.2.bb respectively.

Update addldflags.patch for 1.2 and current Upstream-Status (Accepted).

Add make-docs-optional.patch to avoid building the new doc target which
requires asciidocs. We should add asciidocs and properly package the
docs, but for now it's more important to get the sources current.

Signed-off-by: Darren Hart <dvhart@linux.intel.com>
meta/recipes-kernel/trace-cmd/kernelshark_1.2.bb [moved from meta/recipes-kernel/trace-cmd/kernelshark_git.bb with 81% similarity]
meta/recipes-kernel/trace-cmd/trace-cmd/addldflags.patch
meta/recipes-kernel/trace-cmd/trace-cmd/make-docs-optional.patch [new file with mode: 0644]
meta/recipes-kernel/trace-cmd/trace-cmd_1.2.bb [moved from meta/recipes-kernel/trace-cmd/trace-cmd_git.bb with 76% similarity]

similarity index 81%
rename from meta/recipes-kernel/trace-cmd/kernelshark_git.bb
rename to meta/recipes-kernel/trace-cmd/kernelshark_1.2.bb
index 733bddcc20759e470c3a99af4c83d9df6b914733..aa070a9d9ba51d4fcc95df352ce1bf4f5c9f75c8 100644 (file)
@@ -3,9 +3,9 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
                     file://kernel-shark.c;beginline=6;endline=8;md5=2c22c965a649ddd7973d7913c5634a5e"
 
-SRCREV = "6c696cec3f264a9399241b6e648f58bc97117d49"
-PR = r1
-PV = "1.0.5+git${SRCPV}"
+SRCREV = "7055ffd37beeb44714e86a4abc703f7e175a0db5"
+PR = "r0"
+PV = "1.2+git${SRCPV}"
 
 DEPENDS = "gtk+"
 RDEPENDS_${PN} = "trace-cmd"
@@ -13,7 +13,8 @@ RDEPENDS_${PN} = "trace-cmd"
 inherit pkgconfig
 
 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git;protocol=git \
-           file://addldflags.patch"
+           file://addldflags.patch \
+           file://make-docs-optional.patch"
 S = "${WORKDIR}/git"
 
 EXTRA_OEMAKE = "'CC=${CC}' 'AR=${AR}' 'prefix=${prefix}' gui"
index 8e8f578e61c985fb054aa51fd398fa9204cefe18..14730db90578d79b31950a4bbaf265ce108c6cd4 100644 (file)
@@ -1,29 +1,37 @@
-Upstream-Status: Pending
+trace-cmd: Cross-compile fixes for LDFLAGS and include path
 
 Add ability for the Makefile to respect LDFLAGS.
-
 Also remove hardcoded /usr/local/include include path.
 
-RP 7/5/2011
+Upstream-Status: Accepted [Post 1.2: 5f576e9af7ad706774d9764a9ae3989376797c0e]
+
+Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
+Signed-off-by: Darren Hart <dvhart@linux.intel.com>
+
+---
+ Makefile |    7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
 
 Index: git/Makefile
 ===================================================================
---- git.orig/Makefile  2011-07-05 11:58:11.699910550 +0100
-+++ git/Makefile       2011-07-05 23:30:12.319920617 +0100
-@@ -189,10 +189,11 @@
+--- git.orig/Makefile
++++ git/Makefile
+@@ -202,12 +202,13 @@ export Q VERBOSE
  TRACECMD_VERSION = $(TC_VERSION).$(TC_PATCHLEVEL).$(TC_EXTRAVERSION)
  KERNELSHARK_VERSION = $(KS_VERSION).$(KS_PATCHLEVEL).$(KS_EXTRAVERSION)
  
 -INCLUDES = -I. -I/usr/local/include $(CONFIG_INCLUDES)
 +INCLUDES = -I. $(CONFIG_INCLUDES)
  
+ include features.mk
  # Set compile option CFLAGS if not set elsewhere
  CFLAGS ?= -g -Wall
 +LDFLAGS ?=
  
- # Append required CFLAGS
override CFLAGS += $(CONFIG_FLAGS) $(INCLUDES) $(PLUGIN_DIR_SQ)
-@@ -225,7 +226,7 @@
+ ifndef NO_PTRACE
ifneq ($(call try-cc,$(SOURCE_PTRACE),),y)
+@@ -251,7 +252,7 @@ do_fpic_compile =                                  \
  
  do_app_build =                                                \
        ($(print_app_build)                             \
@@ -32,7 +40,7 @@ Index: git/Makefile
  
  do_compile_shared_library =                   \
        ($(print_shared_lib_compile)            \
-@@ -237,7 +238,7 @@
+@@ -263,7 +264,7 @@ do_compile_plugin_obj =                            \
  
  do_plugin_build =                             \
        ($(print_plugin_build)                  \
diff --git a/meta/recipes-kernel/trace-cmd/trace-cmd/make-docs-optional.patch b/meta/recipes-kernel/trace-cmd/trace-cmd/make-docs-optional.patch
new file mode 100644 (file)
index 0000000..8402426
--- /dev/null
@@ -0,0 +1,36 @@
+Disable building docs until we have asciidocs available as a recipe.
+
+Upstream-Status: Inappropriate [Account for missing dependency, the lazy way]
+
+Signed-off-by: Darren Hart <dvhart@linux.intel.com>
+
+---
+ Makefile |    8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -327,7 +327,9 @@ TARGETS = $(CMD_TARGETS) $(GUI_TARGETS)
+ #    If you want kernelshark, then do:  make gui
+ ###
+-all: all_cmd doc show_gui_make
++# Make doc optional
++#all: all_cmd doc show_gui_make
++all: all_cmd show_gui_make
+ all_cmd: $(CMD_TARGETS)
+@@ -503,7 +505,9 @@ install_python: $(PYTHON_SO_INSTALL) $(P
+ install_cmd: all_cmd install_plugins install_python
+       $(Q)$(call do_install,trace-cmd,$(bindir_SQ))
+-install: install_cmd install_doc
++# Make doc optional
++#install: install_cmd install_doc
++install: install_cmd
+       @echo "Note: to install the gui, type \"make install_gui\""
+ install_gui: install_cmd gui
similarity index 76%
rename from meta/recipes-kernel/trace-cmd/trace-cmd_git.bb
rename to meta/recipes-kernel/trace-cmd/trace-cmd_1.2.bb
index 1278dc7199c4baeb89ee3e557ddb70d28d7de860..1b9231bc1231fc0094a607e9c3887a3203701c7c 100644 (file)
@@ -3,14 +3,15 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
                     file://trace-cmd.c;beginline=6;endline=8;md5=2c22c965a649ddd7973d7913c5634a5e"
 
-SRCREV = "6c696cec3f264a9399241b6e648f58bc97117d49"
-PR = "r2"
-PV = "1.0.5+git${SRCPV}"
+SRCREV = "7055ffd37beeb44714e86a4abc703f7e175a0db5"
+PR = "r0"
+PV = "1.2+git${SRCPV}"
 
 inherit pkgconfig
 
 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git;protocol=git \
-           file://addldflags.patch"
+           file://addldflags.patch \
+           file://make-docs-optional.patch"
 S = "${WORKDIR}/git"
 
 EXTRA_OEMAKE = "'prefix=${prefix}'"