]> code.ossystems Code Review - openembedded-core.git/commitdiff
handbook: Correct a bunch of misc typos.
authorAndrzej Zaborowski <balrog@zabor.org>
Fri, 5 Dec 2008 12:07:12 +0000 (13:07 +0100)
committerAndrzej Zaborowski <balrog@zabor.org>
Fri, 5 Dec 2008 12:07:12 +0000 (13:07 +0100)
handbook/extendpoky.xml
handbook/faq.xml
handbook/introduction.xml
handbook/usingpoky.xml

index cc0dc1fd25f83aa25fb362bccb31a75145c705e7..f259d2ef0a3478f7007ba7fc9432af8552ba800f 100644 (file)
@@ -215,7 +215,7 @@ pkg_postinst_PACKAGENAME () {
             <para>
                 Sometimes it is necessary that the execution of a post-installation
                 script is delayed until the first boot, because the script 
-                needs to be executed the device itself.  To delay script execution
+                needs to be executed on the device itself.  To delay script execution
                 until boot time, the post-installation function should have the
                 following structure:
             </para>
@@ -268,7 +268,7 @@ inherit poky-image
 
             <para>
                 By creating a custom image, a developer has total control
-                over the contents of the image. It is important use 
+                over the contents of the image. It is important to use 
                 the correct names of packages in the <glossterm><link
                 linkend='var-IMAGE_INSTALL'>IMAGE_INSTALL</link></glossterm> variable. 
                 The names must be in 
@@ -295,11 +295,11 @@ IMAGE_INSTALL += "strace"
             <title>Customising Images through custom tasks</title>
 
             <para>
-                For for complex custom images, the best approach is to create a custom 
-                task package which is them used to build the image (or images). A good
+                For complex custom images, the best approach is to create a custom 
+                task package which is then used to build the image (or images). A good
                 example of a tasks package is <filename>meta/packages/tasks/task-poky.bb
                 </filename>. The <glossterm><link linkend='var-PACKAGES'>PACKAGES</link></glossterm> 
-                variable lists the task packages to build (along with the complimentary
+                variable lists the task packages to build (along with the complementary
                 -dbg and -dev packages). For each package added,
                 <glossterm><link linkend='var-PACKAGES'>RDEPENDS</link></glossterm> and
                 <glossterm><link linkend='var-PACKAGES'>RRECOMMENDS</link></glossterm> 
index 7f5c4a962d4ad1ac5e9187adfcf53ce563512fdd..518069ed2a9d3a69ce2bfe3ae7273982a23e71a8 100644 (file)
                In Intrepid, Ubuntu turned on by default normally optional compile-time security features 
                and warnings. There are more details at <ulink
                 url='https://wiki.ubuntu.com/CompilerFlags'>https://wiki.ubuntu.com/CompilerFlags</ulink>.
-               You can work around this problem by disbaling those options by adding " -Wno-format-security -U_FORTIFY_SOURCE" 
+               You can work around this problem by disabling those options by adding " -Wno-format-security -U_FORTIFY_SOURCE" 
                to the BUILD_CPPFLAGS variable in conf/bitbake.conf.
             </para>
         </answer>
index 7697bcd0cc0a2158a9616749c9a05e3b1af73cd9..fd26b810977c85c7280d3bb1fce0dc92fea1c472 100644 (file)
@@ -69,7 +69,8 @@
 
     <para>
 
-    Poky has a growing open source community backed up by commercial support provided by the principle developer and maintainer of Poky, <ulink url="http://o-hand.com/">OpenedHand Ltd</ulink>.
+    Poky has a growing open source community backed up by commercial support
+provided by the principal developer and maintainer of Poky, <ulink url="http://o-hand.com/">OpenedHand Ltd</ulink>.
 
     </para>
 </section>
index c30da0716d063348ee945b33175dcc04fe3027aa..d54765c78606ee35e37f267a12779c2a0d7d4460 100644 (file)
@@ -75,7 +75,7 @@
         </para>
 
         <para>
-            'package' can also used to describe recipes but since the same
+            'package' can also be used to describe recipes but since the same
             word is used for the packaged output from Poky (i.e. .ipk or .deb
             files), this document will avoid it.
         </para>
     <title>Running a Build</title>
 
     <para>
-        First the Poky build environment needs to be setup using the following command:
+        First the Poky build environment needs to be set up using the following command:
     </para>
     <para>
         <literallayout class='monospaced'>
@@ -122,7 +122,7 @@ $ source poky-init-build-env
 </literallayout>
     </para>
     <para>
-        Once the Poky build environment is setup, a target can now be built using:
+        Once the Poky build environment is set up, a target can now be built using:
     </para>
     <para>
         <literallayout class='monospaced'>
@@ -204,11 +204,11 @@ route add default gw 192.168.7.200 tap0
         <para>
             The second is to configure name resolution which is configured in the 
             <filename>/etc/resolv.conf</filename> file. The simplest solution is 
-            to copy it's content from the host machine.
+            to copy its content from the host machine.
         </para>
 
         <para>
-            USB connections to devices can be setup and automated in a similar way.
+            USB connections to devices can be set up and automated in a similar way.
             First add the following to
             <filename>/etc/network/interfaces</filename>:
         </para>
@@ -246,7 +246,7 @@ route add default gw 192.168.0.202 usb0
         debugging practises such as comparing to the last 
         known working version and examining the changes, reapplying the 
         changes in steps to identify the one causing the problem etc. are
-        valid for Poky just like any other system. Its impossible to detail
+        valid for Poky just like any other system. It's impossible to detail
         every possible potential failure here but there are some general
         tips to aid debugging:
     </para>
@@ -293,7 +293,7 @@ route add default gw 192.168.0.202 usb0
         <para>
             which would build matchbox-desktop, then recompile it. The
             final command reruns all tasks after the compile (basically
-            the packaging tasks) since bitbake will notice the the
+            the packaging tasks) since bitbake will notice that the
             compile has been rerun and hence the other tasks also need
             to run again.
         </para>