]> code.ossystems Code Review - openembedded-core.git/commitdiff
tweaked to work with autotooled package
authorTomas Frydrych <tf@openedhand.com>
Fri, 3 Nov 2006 09:20:26 +0000 (09:20 +0000)
committerTomas Frydrych <tf@openedhand.com>
Fri, 3 Nov 2006 09:20:26 +0000 (09:20 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@853 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/exmap-console/exmap-console.bb

index e4af4c1be46b161b150c740b58866fd5f181e7c9..929b27970af637ed55bbd4fa7781d2a81e2c28af 100644 (file)
@@ -2,19 +2,20 @@ DESCRIPTION = "console-based exmap"
 HOMEPAGE = "http://www.o-hand.com"
 SECTION = "devel"
 LICENSE = "GPL"
-PR = "r3"
+PR = "r5"
 PV = "0.9"
 
-SRCDATE="20061026"
+SRCDATE="20061104"
 
 SRC_URI = \
     "svn://svn.o-hand.com/repos/misc/trunk;module=exmap-console;proto=http"
 
 inherit module-base
+inherit autotools
 
 S = "${WORKDIR}/exmap-console"
 
-export KERNEL_PATH=${STAGING_KERNEL_DIR}
+export MODULE_PATH="${D}${base_libdir}/modules/${KERNEL_VERSION}"
 
 do_compile() {
        cd ${S}/src
@@ -29,14 +30,4 @@ do_compile() {
                   ${MAKE_TARGETS}
 }
 
-sbindir="/usr/sbin"
-
-do_install() {
-       install -d ${D}${sbindir}
-       install -m 710 ${S}/src/exmap ${D}${sbindir}/exmap
-
-       install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/misc
-       install -m 644 ${S}/kernel/exmap${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/misc/
-}
-
 FILES_${PN}="${sbindir} ${base_libdir}"