]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/5.4: perf: Alias SYS_futex with SYS_futex_time64 on 32-bit arches with...
authorBruce Ashfield <bruce.ashfield@gmail.com>
Thu, 19 Nov 2020 19:17:49 +0000 (14:17 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Nov 2020 10:27:38 +0000 (10:27 +0000)
Integrating the following commit(s) to linux-yocto/5.4:

    356914747645 perf: Alias SYS_futex with SYS_futex_time64 on 32-bit arches with 64bit time_t

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
meta/recipes-kernel/linux/linux-yocto_5.4.bb

index 183acce2261d0ed4c20dfba08497db96e6abdfc5..4db2b33aefdcd4cbc25b67e260a719d166136c68 100644 (file)
@@ -11,7 +11,7 @@ python () {
         raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
 }
 
-SRCREV_machine ?= "e500e89811e268ab5c420744c41b10d12c9844a0"
+SRCREV_machine ?= "1fe1ef9c7272caf75d92b3e9166a0f29c4f06141"
 SRCREV_meta ?= "8d0ed83a864cc91eef4d2abbc90f13d4ecd1c213"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
index f6190be8da3353b0da18935f69971681b6d904bd..f6ed7f35ea227e4c99363b5a1ff7752da2fc550c 100644 (file)
@@ -15,8 +15,8 @@ DEPENDS += "openssl-native util-linux-native"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine_qemuarm ?= "2c7da912c6b5bd36d84f75e0aff4afd0814f1bd3"
-SRCREV_machine ?= "d0096198f08dd2aa4222ef5480d2fcdaf520b65b"
+SRCREV_machine_qemuarm ?= "83d064534da33ab41108a786d917068f282a9bf2"
+SRCREV_machine ?= "356914747645db5ceba98b22acdfa060ef1764af"
 SRCREV_meta ?= "8d0ed83a864cc91eef4d2abbc90f13d4ecd1c213"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
index 23fc5ea819207eb1174b145c94c715500506db66..0330a9d159821efdbd625bc02fde8a2e85ce51cc 100644 (file)
@@ -12,15 +12,15 @@ KBRANCH_qemux86  ?= "v5.4/standard/base"
 KBRANCH_qemux86-64 ?= "v5.4/standard/base"
 KBRANCH_qemumips64 ?= "v5.4/standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "dbac8d2939bca0a92226cfd55543331715dd642d"
-SRCREV_machine_qemuarm64 ?= "d0096198f08dd2aa4222ef5480d2fcdaf520b65b"
-SRCREV_machine_qemumips ?= "819cf265755f21768f6bb98312cb568c6db8b1e8"
-SRCREV_machine_qemuppc ?= "d0096198f08dd2aa4222ef5480d2fcdaf520b65b"
-SRCREV_machine_qemuriscv64 ?= "d0096198f08dd2aa4222ef5480d2fcdaf520b65b"
-SRCREV_machine_qemux86 ?= "d0096198f08dd2aa4222ef5480d2fcdaf520b65b"
-SRCREV_machine_qemux86-64 ?= "d0096198f08dd2aa4222ef5480d2fcdaf520b65b"
-SRCREV_machine_qemumips64 ?= "bb9110d96ce8a2c56466e5b4314b93175af3d80d"
-SRCREV_machine ?= "d0096198f08dd2aa4222ef5480d2fcdaf520b65b"
+SRCREV_machine_qemuarm ?= "879db1ae1856cf5a9fe4609fdbcbe2e3c7bade5f"
+SRCREV_machine_qemuarm64 ?= "356914747645db5ceba98b22acdfa060ef1764af"
+SRCREV_machine_qemumips ?= "190c3ce9c2dbc709c3dcf02d8cfa80adc8a063d2"
+SRCREV_machine_qemuppc ?= "356914747645db5ceba98b22acdfa060ef1764af"
+SRCREV_machine_qemuriscv64 ?= "356914747645db5ceba98b22acdfa060ef1764af"
+SRCREV_machine_qemux86 ?= "356914747645db5ceba98b22acdfa060ef1764af"
+SRCREV_machine_qemux86-64 ?= "356914747645db5ceba98b22acdfa060ef1764af"
+SRCREV_machine_qemumips64 ?= "98b1fc2eafc28e5c198e23579e38a76626c66182"
+SRCREV_machine ?= "356914747645db5ceba98b22acdfa060ef1764af"
 SRCREV_meta ?= "8d0ed83a864cc91eef4d2abbc90f13d4ecd1c213"
 
 # remap qemuarm to qemuarma15 for the 5.4 kernel