]> code.ossystems Code Review - openembedded-core.git/commitdiff
man-pages:Add new man-pages package
authorXiaofeng Yan <xiaofeng.yan@windriver.com>
Thu, 2 Sep 2010 08:49:26 +0000 (16:49 +0800)
committerSaul Wold <Saul.Wold@intel.com>
Wed, 8 Sep 2010 23:36:53 +0000 (16:36 -0700)
The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs

Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
meta/recipes-extended/man-pages/man-pages_3.25.bb [new file with mode: 0644]

diff --git a/meta/recipes-extended/man-pages/man-pages_3.25.bb b/meta/recipes-extended/man-pages/man-pages_3.25.bb
new file mode 100644 (file)
index 0000000..93cb70a
--- /dev/null
@@ -0,0 +1,29 @@
+DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
+SECTION = "console/utils"
+PRIORITY = "required"
+HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
+LICENSE = "GPL"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://README;md5=9dab010c5baa416669e5d17381799dd5"
+SRC_URI = "http://www.kernel.org/pub/linux/docs/man-pages/man-pages-3.25.tar.gz"
+
+RDEPENDS = "man"
+
+do_configure_prepend() {
+       rm -rf not_installed
+}
+
+do_configure () {
+      :
+}
+
+do_compile() {
+       oe_runmake -f Makefile DESTDIR=${D} MANDIR=${D}${mandir}
+}
+
+fakeroot do_install() {
+        oe_runmake install DESTDIR=${D}
+}
+
+FILES_${PN} += "${datadir}/man/"