]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: link udev statically with systemd internal libraries
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Thu, 22 Mar 2018 13:47:37 +0000 (15:47 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 25 Mar 2018 08:33:36 +0000 (09:33 +0100)
This was the default behavior with autotools, but is not with meson.
Otherwise, udev package will pull in the rest of systemd even
that is not desired.

[YOCTO #12618]

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/systemd/systemd_237.bb

index b1c976fc5be275b8fc32eaf0195cb1380a7634be..7ef42b2eaedb6cde23d0f4fc22b21c8937a63f02 100644 (file)
@@ -168,6 +168,11 @@ rootprefix ?= "${root_prefix}"
 rootlibdir ?= "${base_libdir}"
 rootlibexecdir = "${rootprefix}/lib"
 
+# This links udev statically with systemd helper library.
+# Otherwise udev package would depend on systemd package (which has the needed shared library),
+# and always pull it into images.
+EXTRA_OEMESON += "-Dlink-udev-shared=false"
+
 EXTRA_OEMESON += "-Dnobody-user=nobody \
                   -Dnobody-group=nobody \
                   -Droothomedir=${ROOTHOME} \