]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa-dri: upgrade from 7.8.2 to 7.9
authorYu Ke <ke.yu@intel.com>
Wed, 24 Nov 2010 04:51:42 +0000 (12:51 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 2 Dec 2010 13:24:57 +0000 (05:24 -0800)
with the following changes:

- remove mesa-demos, because starting from mesa 7.9,
  mesa-demos becomes a standalone src tar ball in
  upstream, so there will be a seperate recipes to
  build the mesa-demos

- add dependency of talloc and libxml2-native

Signed-off-by: Yu Ke <ke.yu@intel.com>
meta/conf/distro/include/preferred-xorg-versions.inc
meta/recipes-graphics/mesa/mesa-dri_7.9.bb [moved from meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb with 54% similarity]

index 5efd663f116baf59b2d1c76fbbeb43a9a8ff5c58..750767ba7a7cd414add5b04eb5bc751e7b4c5b2d 100644 (file)
@@ -136,7 +136,7 @@ PREFERRED_VERSION_xtrans-native ?= "1.2.6"
 PREFERRED_VERSION_xtrans-nativesdk ?= "1.2.6"
 PREFERRED_VERSION_xvinfo ?= "1.0.2"
 PREFERRED_VERSION_xwininfo ?= "1.1.0"
-PREFERRED_VERSION_mesa-dri ?= "7.8.2"
+PREFERRED_VERSION_mesa-dri ?= "7.9"
 PREFERRED_VERSION_libdrm ?= "2.4.22"
 PREFERRED_VERSION_xcb-proto ?= "1.6"
 PREFERRED_VERSION_libxcb ?= "1.7"
similarity index 54%
rename from meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb
rename to meta/recipes-graphics/mesa/mesa-dri_7.9.bb
index caa9b2ecbc87c77dacfc6ebbdb0e3610cd72139d..6f0f984022e81d92d3602cdb6dbb85e6b3e81534 100644 (file)
@@ -3,13 +3,15 @@ include mesa-common.inc
 LIC_FILES_CHKSUM = "file://docs/license.html;md5=7a3373c039b6b925c427755a4f779c1d"
 
 PROTO_DEPS = "xf86driproto glproto dri2proto"
-LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat"
+LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat \
+            libxml2-native talloc"
 
 DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS} mesa-dri-glsl-native"
 
-PR = "r2"
+PR = "r0"
 
-SRC_URI += "file://crossfix.patch"
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
+           file://crossfix.patch"
 
 # most of our targets do not have DRI so will use mesa-xlib
 DEFAULT_PREFERENCE = "-1"
@@ -21,16 +23,6 @@ LEAD_SONAME = "libGL.so.1"
 
 EXTRA_OECONF += "--with-driver=dri --disable-egl --disable-gallium"
 
-# We need glsl-compile built for buildhost arch instead of target (is provided by mesa-dri-glsl-native)"
-do_configure_prepend() {
-       sed -i "s#^GLSL_CL = .*\$#GLSL_CL = ${STAGING_BINDIR_NATIVE}/glsl-compile#g" ${S}/src/mesa/shader/slang/library/Makefile
-}
-
-do_install_append () {
-       install -d ${D}/usr/bin
-       install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/usr/bin/
-}
-
 python populate_packages_prepend() {
        import os.path
 
@@ -41,13 +33,6 @@ python populate_packages_prepend() {
 
 COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)'
 
-PACKAGES =+ "${PN}-xprogs"
 PACKAGES_DYNAMIC = "mesa-dri-driver-*"
 
 FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
-FILES_${PN}-xprogs = "${bindir}/glxdemo ${bindir}/glxgears ${bindir}/glxheads ${bindir}/glxinfo"
-
-#
-# Header generated by i586-poky-linux-gcc gen_matypes.c -o gen_matypes -I ../../../include/GL -I ../../../include -I .. -I ../main/ -I ../math -I ../glapi/ -I ../tnl
-# then run gen_matypes > matypes.h on device
-#