]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemuwrapper: Don't use STAGING_BINDIR_CROSS directly
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 7 Feb 2013 12:40:35 +0000 (12:40 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 7 Feb 2013 12:58:57 +0000 (12:58 +0000)
We need the files to be tracked by sstate so we need to jump through
some hoops to ensure this happens. The cross bindir directory
isn't staged automatically so we need to handle this outselves.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb

index dc160474517f5716383b71465d14fdf699cc69f1..f23a7d796280d631cc0e318b6d2185cd9ba1e377 100644 (file)
@@ -6,9 +6,15 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384
 inherit qemu
 
 do_install () {
-    install -d ${STAGING_BINDIR_CROSS}
+       install -d ${D}${bindir_crossscripts}/
 
-    echo "#!/bin/sh" > ${STAGING_BINDIR_CROSS}/qemuwrapper
-    echo exec env ${@qemu_target_binary(d)} \"\$@\" >> ${STAGING_BINDIR_CROSS}/qemuwrapper
-    chmod +x ${STAGING_BINDIR_CROSS}/qemuwrapper
+       echo "#!/bin/sh" > ${D}${bindir_crossscripts}/qemuwrapper
+       echo exec env ${@qemu_target_binary(d)} \"\$@\" >> ${D}${bindir_crossscripts}/qemuwrapper
+       chmod +x ${D}${bindir_crossscripts}/qemuwrapper
+}
+
+SYSROOT_PREPROCESS_FUNCS += "qemuwrapper_sysroot_preprocess"
+
+qemuwrapper_sysroot_preprocess () {
+       sysroot_stage_dir ${D}${bindir_crossscripts} ${SYSROOT_DESTDIR}${bindir_crossscripts}
 }